summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-06-29 16:41:12 -0500
committerLuis Martinez2021-06-29 16:41:15 -0500
commit09e7282ad385021d5f90084fe5204eacadd18010 (patch)
treec9e5fb70b775ebd8d6d0ec65749099eff74b4397
parenta06b74c1463d2dcd39e04a6665d130f407f34b06 (diff)
downloadaur-09e7282ad385021d5f90084fe5204eacadd18010.tar.gz
cleanup
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ae10ea54393..74b6b4ee9264 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = python-pypresence
pkgdesc = A complete Discord RPC and Rich Presence wrapper library in Python
pkgver = 4.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://qwertyquerty.github.io/pypresence/html/index.html
arch = any
license = MIT
makedepends = python-setuptools
- depends = python
+ depends = python>=3.5
source = https://files.pythonhosted.org/packages/source/p/pypresence/pypresence-4.2.0.tar.gz
- source = https://raw.githubusercontent.com/qwertyquerty/pypresence/master/LICENSE
- md5sums = 87fb41e2a5a353a4ec8e74169da87a69
- md5sums = 43c3642351bf4af10745d33f4b301aad
+ source = LICENSE-4.2.0::https://raw.githubusercontent.com/qwertyquerty/pypresence/4.2.0/LICENSE
+ sha256sums = 54618a18085d104aa063df8296dac95cf01b922ed8aab4b021f71718bb3f19b1
+ sha256sums = a3286e2d54c65b24c18fb69c714fd19318f3ce9b36a816f198d2cae28c77dfc3
pkgname = python-pypresence
-
diff --git a/PKGBUILD b/PKGBUILD
index de8a35f36f90..bfb366f5c9fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,28 @@
-# Maintainer: Ronan Pigott <rpigott@berkeley.edu>
+# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Contributor: Ronan Pigott <rpigott@berkeley.edu>
-pkgname='python-pypresence'
+pkgname=python-pypresence
pkgver=4.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='A complete Discord RPC and Rich Presence wrapper library in Python'
url='https://qwertyquerty.github.io/pypresence/html/index.html'
arch=('any')
license=('MIT')
+depends=('python>=3.5')
makedepends=('python-setuptools')
-depends=('python')
source=("https://files.pythonhosted.org/packages/source/p/pypresence/pypresence-$pkgver.tar.gz"
- "https://raw.githubusercontent.com/qwertyquerty/pypresence/master/LICENSE")
-md5sums=('87fb41e2a5a353a4ec8e74169da87a69'
- '43c3642351bf4af10745d33f4b301aad')
+ "LICENSE-$pkgver::https://raw.githubusercontent.com/qwertyquerty/pypresence/$pkgver/LICENSE")
+sha256sums=('54618a18085d104aa063df8296dac95cf01b922ed8aab4b021f71718bb3f19b1'
+ 'a3286e2d54c65b24c18fb69c714fd19318f3ce9b36a816f198d2cae28c77dfc3')
+
build() {
cd "${srcdir}/pypresence-${pkgver}"
python setup.py build
}
package() {
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "LICENSE-$pkgver" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
cd "${srcdir}/pypresence-${pkgver}"
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
}