summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Meusel2017-04-07 01:43:24 +0200
committerTim Meusel2017-04-07 01:43:24 +0200
commitee2fe458ac58454d8c63b397ba17386424e62cc8 (patch)
tree024f339b2ae11eb7021cb605b6fbb255e2e4f6b6
parent21bfe52408eeaccdc12daca7bd5641a15a0c8424 (diff)
downloadaur-ee2fe458ac58454d8c63b397ba17386424e62cc8.tar.gz
release 0.3.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 36 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ab123e3bd6c..74b0e4c39495 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,21 @@
pkgbase = python-pypuppetdb
- pkgver = 0.3.1
+ pkgver = 0.3.2
pkgrel = 1
- url = https://github.com/puppet-community/pypuppetdb
+ url = https://github.com/voxpupuli/pypuppetdb
arch = any
license = APACHE
+ checkdepends = python2-pbr
+ checkdepends = python-pytest-cov
+ checkdepends = python-mock
+ checkdepends = python-httpretty
makedepends = python
makedepends = python2
makedepends = python-setuptools
makedepends = python2-setuptools
- source = https://github.com/puppet-community/pypuppetdb/archive/v0.3.1.tar.gz
- sha512sums = 7ad85971c7582a20e7d357aff456f5ed63c31e887573e754cb818c21148a3997c6dd3e2287726bffd339f440535fb8bc9d3423ef86ea834f914b5a5d8f3fef59
+ makedepends = python-sphinx
+ makedepends = bandit
+ source = python2-pypuppetdb-0.3.2.tar.gz::https://github.com/voxpupuli/pypuppetdb/archive/v0.3.2.tar.gz
+ sha512sums = b402850ad40e40c544923de3556385249559a42c898eda257a3431b91d4b237c354a3165bb208641e3133b36ce510797fe6471626be8a64716e67c2913d12756
pkgname = python2-pypuppetdb
pkgdesc = Python library for working with the PuppetDB API (Python 2 version)
@@ -19,7 +25,7 @@ pkgname = python2-pypuppetdb
pkgname = python-pypuppetdb
pkgdesc = Python library for working with the PuppetDB API (Python 3 version)
- depends = python
+ depends = python>=3.3.0-1
depends = python-requests
depends = python-httpretty
diff --git a/PKGBUILD b/PKGBUILD
index 28bb54512360..9fd1bb694b43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,46 @@
# PyPuppetDB: Installer: Arch
# Maintainer: Tim Meusel <tim@bastelfreak.de>
-# Contributor Florian Pritz <bluewind@xinu.at>
+# Contributor: Florian Pritz <bluewind@xinu.at>
+# Contributor: Christian Rebischke <chris.rebischke@archlinux.org>
pkgbase=python-pypuppetdb
pkgname=('python2-pypuppetdb' 'python-pypuppetdb')
-pkgver=0.3.1
+pkgver=0.3.2
pkgrel=1
arch=('any')
-url='https://github.com/puppet-community/pypuppetdb'
+url='https://github.com/voxpupuli/pypuppetdb'
license=('APACHE')
-makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools')
-source=("https://github.com/puppet-community/pypuppetdb/archive/v${pkgver}.tar.gz")
-sha512sums=('7ad85971c7582a20e7d357aff456f5ed63c31e887573e754cb818c21148a3997c6dd3e2287726bffd339f440535fb8bc9d3423ef86ea834f914b5a5d8f3fef59')
+makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools' 'python-sphinx' 'bandit')
+checkdepends=('python2-pbr' 'python-pytest-cov' 'python-mock' 'python-httpretty')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/voxpupuli/pypuppetdb/archive/v${pkgver}.tar.gz")
+sha512sums=('b402850ad40e40c544923de3556385249559a42c898eda257a3431b91d4b237c354a3165bb208641e3133b36ce510797fe6471626be8a64716e67c2913d12756')
+
+check() {
+ cd "${srcdir}/pypuppetdb-${pkgver}"
+ #py.test --cov=pypuppetdb -v # <- currently broken upstream
+ ./bandit.sh
+}
package_python2-pypuppetdb() {
pkgdesc='Python library for working with the PuppetDB API (Python 2 version)'
depends=('python2' 'python2-requests' 'python2-httpretty')
cd "${srcdir}/pypuppetdb-${pkgver}"
- python2 setup.py install --root=${pkgdir}/ --optimize=1
+ python2 setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd docs
+ make man
+ install -D -m644 "${srcdir}/pypuppetdb-${pkgver}/docs/_build/man/pypuppetdb.1" "${pkgdir}/usr/share/man/man1/pypuppetdb.1"
}
package_python-pypuppetdb() {
- depends=('python' 'python-requests' 'python-httpretty')
+ depends=('python>=3.3.0-1' 'python-requests' 'python-httpretty')
pkgdesc='Python library for working with the PuppetDB API (Python 3 version)'
cd "${srcdir}/pypuppetdb-${pkgver}"
- python setup.py install --root=${pkgdir}/ --optimize=1
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ cd docs
+ make man
+ install -D -m644 "${srcdir}/pypuppetdb-${pkgver}/docs/_build/man/pypuppetdb.1" "${pkgdir}/usr/share/man/man1/pypuppetdb.1"
}
# vim:set ts=2 sw=2 et: