summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212021-11-29 23:49:46 +0100
committera8212021-11-29 23:49:46 +0100
commitee537d5ae0ee64e4c6f70af5ec47dcbb17972b7f (patch)
tree416b5563b5e33e9fe41cac55db1d2b5022d4c3cc
parentee2fe458ac58454d8c63b397ba17386424e62cc8 (diff)
downloadaur-ee537d5ae0ee64e4c6f70af5ec47dcbb17972b7f.tar.gz
Version 2.5.1
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD52
2 files changed, 27 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74b0e4c39495..f1ea078fdd92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,31 +1,17 @@
pkgbase = python-pypuppetdb
- pkgver = 0.3.2
+ pkgdesc = Library for working with the PuppetDB REST API
+ pkgver = 2.5.1
pkgrel = 1
url = https://github.com/voxpupuli/pypuppetdb
arch = any
- license = APACHE
- checkdepends = python2-pbr
+ license = Apache
checkdepends = python-pytest-cov
checkdepends = python-mock
checkdepends = python-httpretty
- makedepends = python
- makedepends = python2
makedepends = python-setuptools
- makedepends = python2-setuptools
- makedepends = python-sphinx
- makedepends = bandit
- source = python2-pypuppetdb-0.3.2.tar.gz::https://github.com/voxpupuli/pypuppetdb/archive/v0.3.2.tar.gz
- sha512sums = b402850ad40e40c544923de3556385249559a42c898eda257a3431b91d4b237c354a3165bb208641e3133b36ce510797fe6471626be8a64716e67c2913d12756
-
-pkgname = python2-pypuppetdb
- pkgdesc = Python library for working with the PuppetDB API (Python 2 version)
- depends = python2
- depends = python2-requests
- depends = python2-httpretty
-
-pkgname = python-pypuppetdb
- pkgdesc = Python library for working with the PuppetDB API (Python 3 version)
- depends = python>=3.3.0-1
+ makedepends = python-sphinx_rtd_theme
depends = python-requests
- depends = python-httpretty
+ source = python-pypuppetdb-2.5.1.tar.gz::https://github.com/voxpupuli/pypuppetdb/archive/refs/tags/v2.5.1.tar.gz
+ sha512sums = 1ce4a47bab6806325d4a382ea99513f92eda0e8ae9d834e04db6ae209a520ac6bb887a912583f0a4e36f000f97833902bb8e8340f5648b2a4080b8ffb0af741a
+pkgname = python-pypuppetdb
diff --git a/PKGBUILD b/PKGBUILD
index 9fd1bb694b43..1a583cc2b118 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,34 @@
-# PyPuppetDB: Installer: Arch
-# Maintainer: Tim Meusel <tim@bastelfreak.de>
+# Contributor: Tim Meusel <tim@bastelfreak.de>
# Contributor: Florian Pritz <bluewind@xinu.at>
# Contributor: Christian Rebischke <chris.rebischke@archlinux.org>
-pkgbase=python-pypuppetdb
-pkgname=('python2-pypuppetdb' 'python-pypuppetdb')
-pkgver=0.3.2
+pkgname=python-pypuppetdb
+pkgver=2.5.1
pkgrel=1
+pkgdesc='Library for working with the PuppetDB REST API'
arch=('any')
url='https://github.com/voxpupuli/pypuppetdb'
-license=('APACHE')
-makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools' 'python-sphinx' 'bandit')
-checkdepends=('python2-pbr' 'python-pytest-cov' 'python-mock' 'python-httpretty')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/voxpupuli/pypuppetdb/archive/v${pkgver}.tar.gz")
-sha512sums=('b402850ad40e40c544923de3556385249559a42c898eda257a3431b91d4b237c354a3165bb208641e3133b36ce510797fe6471626be8a64716e67c2913d12756')
+license=('Apache')
+depends=('python-requests')
+makedepends=('python-setuptools' 'python-sphinx_rtd_theme')
+checkdepends=('python-pytest-cov' 'python-mock' 'python-httpretty')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/voxpupuli/pypuppetdb/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('1ce4a47bab6806325d4a382ea99513f92eda0e8ae9d834e04db6ae209a520ac6bb887a912583f0a4e36f000f97833902bb8e8340f5648b2a4080b8ffb0af741a')
check() {
- cd "${srcdir}/pypuppetdb-${pkgver}"
- #py.test --cov=pypuppetdb -v # <- currently broken upstream
- ./bandit.sh
+ cd ${pkgname#python-}-${pkgver}
+ sed -i '/pep8maxlinelength/d' pytest.ini
+ pytest
}
-package_python2-pypuppetdb() {
- pkgdesc='Python library for working with the PuppetDB API (Python 2 version)'
- depends=('python2' 'python2-requests' 'python2-httpretty')
- cd "${srcdir}/pypuppetdb-${pkgver}"
- python2 setup.py install --root="${pkgdir}/" --optimize=1
- install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- cd docs
- make man
- install -D -m644 "${srcdir}/pypuppetdb-${pkgver}/docs/_build/man/pypuppetdb.1" "${pkgdir}/usr/share/man/man1/pypuppetdb.1"
-}
-
-package_python-pypuppetdb() {
- depends=('python>=3.3.0-1' 'python-requests' 'python-httpretty')
- pkgdesc='Python library for working with the PuppetDB API (Python 3 version)'
- cd "${srcdir}/pypuppetdb-${pkgver}"
+package() {
+ cd ${pkgname#python-}-${pkgver}
python setup.py install --root="${pkgdir}/" --optimize=1
- install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -rf "${pkgdir}"/usr/requirements_for_tests
+
cd docs
- make man
- install -D -m644 "${srcdir}/pypuppetdb-${pkgver}/docs/_build/man/pypuppetdb.1" "${pkgdir}/usr/share/man/man1/pypuppetdb.1"
+ PYTHONPATH=.. make man
+ install -D -m644 "_build/man/pypuppetdb.1" "${pkgdir}/usr/share/man/man1/pypuppetdb.1"
}
-# vim:set ts=2 sw=2 et:
+# vim:set ts=2 sw=2 et: