summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSefa Eyeoglu2020-02-26 20:54:45 +0100
committerSefa Eyeoglu2020-02-26 20:54:45 +0100
commitdb60ff7be6a5d5250e71d4cd96747a0fd1bbd44e (patch)
tree998bb0ba4f607c030c422b9759dd60a72cea57cb
downloadaur-db60ff7be6a5d5250e71d4cd96747a0fd1bbd44e.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f1c348a1df16
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pyqis-git
+ pkgdesc = Python QIS client for German university information servers
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://gitlab.com/Scrumplex/pyqis
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-requests
+ depends = python-beautifulsoup4
+ depends = python-lxml
+ source = python-pyqis::git+https://gitlab.com/Scrumplex/pyqis.git#tag=0.0.1
+ sha512sums = SKIP
+
+pkgname = python-pyqis-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..257bdce8337b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+
+_pkgname=python-pyqis
+pkgname=${_pkgname}-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Python QIS client for German university information servers"
+arch=(any)
+url="https://gitlab.com/Scrumplex/pyqis"
+license=("GPL3")
+depends=("python-requests" "python-beautifulsoup4" "python-lxml")
+makedepends=("git" "python-setuptools")
+source=("${_pkgname}::git+https://gitlab.com/Scrumplex/pyqis.git#tag=${pkgver}")
+sha512sums=(SKIP)
+
+build() {
+ cd "$_pkgname"
+
+ python setup.py build
+}
+
+package() {
+ cd "$_pkgname"
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}