summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoracxz2022-04-02 01:25:46 -0400
committeracxz2022-04-02 01:27:06 -0400
commit6e712e6c588d550a1a6f83c1b37c2c9135aae6ba (patch)
tree73909ae8eab7ffc1a0dc923b17412e55ec49b95d
downloadaur-6e712e6c588d550a1a6f83c1b37c2c9135aae6ba.tar.gz
initial commit
-rw-r--r--.SRCINFO51
-rw-r--r--PKGBUILD67
-rw-r--r--restore-sip4-support.patch12
3 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c9e4fc089e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,51 @@
+pkgbase = python-pyqt5-sip4
+ pkgdesc = A set of Python bindings for the Qt5 toolkit
+ pkgver = 5.15.6
+ pkgrel = 1
+ url = https://riverbankcomputing.com/software/pyqt/intro
+ arch = x86_64
+ groups = pyqt5
+ license = GPL
+ makedepends = sip
+ makedepends = pyqt-builder
+ makedepends = python-opengl
+ makedepends = python-dbus
+ makedepends = qt5-connectivity
+ makedepends = qt5-multimedia
+ makedepends = qt5-tools
+ makedepends = qt5-serialport
+ makedepends = qt5-speech
+ makedepends = qt5-svg
+ makedepends = qt5-webkit
+ makedepends = qt5-websockets
+ makedepends = qt5-x11extras
+ makedepends = qt5-xmlpatterns
+ makedepends = qt5-remoteobjects
+ makedepends = qt5-quick3d
+ depends = python-pyqt5-sip
+ depends = qt5-base
+ optdepends = python-opengl: enable OpenGL 3D graphics in PyQt applications
+ optdepends = python-dbus: for python-dbus mainloop support
+ optdepends = qt5-multimedia: QtMultimedia, QtMultimediaWidgets
+ optdepends = qt5-tools: QtHelp, QtDesigner
+ optdepends = qt5-svg: QtSvg
+ optdepends = qt5-webkit: QtWebKit, QtWebKitWidgets
+ optdepends = qt5-xmlpatterns: QtXmlPatterns
+ optdepends = qt5-declarative: QtQml, qmlplugin
+ optdepends = qt5-serialport: QtSerialPort
+ optdepends = qt5-websockets: QtWebSockets
+ optdepends = qt5-connectivity: QtNfc, QtBluetooth
+ optdepends = qt5-x11extras: QtX11Extras
+ optdepends = qt5-remoteobjects: QtRemoteObjects
+ optdepends = qt5-speech: QtTextToSpeech
+ optdepends = qt5-quick3d: QtQuick3D
+ provides = qt5-python-bindings
+ provides = python-pyqt5
+ conflicts = pyqt5-common
+ conflicts = python-pyqt5
+ source = https://pypi.python.org/packages/source/P/PyQt5/PyQt5-5.15.6.tar.gz
+ source = restore-sip4-support.patch
+ sha256sums = 80343bcab95ffba619f2ed2467fd828ffeb0a251ad7225be5fc06dcc333af452
+ sha256sums = c8881a8dc666e509773f93330615d310f9f040c2167dc9e98843741691395f72
+
+pkgname = python-pyqt5-sip4
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26cb9ec28ae8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+# Contributor: Antonio Rojas <arojas@archlinux.org>
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# Contributor: Yichao Yu <yyc1992@gmail.com>
+# Contributor: Douglas Soares de Andrade <douglas@archlinux.org>
+# Contributor: riai <riai@bigfoot.com> Ben <ben@benmazer.net>
+
+pkgname=('python-pyqt5-sip4')
+pkgdesc="A set of Python bindings for the Qt5 toolkit"
+pkgver=5.15.6
+pkgrel=1
+arch=('x86_64')
+url="https://riverbankcomputing.com/software/pyqt/intro"
+license=('GPL')
+groups=(pyqt5)
+depends=('python-pyqt5-sip' 'qt5-base')
+optdepends=('python-opengl: enable OpenGL 3D graphics in PyQt applications'
+ 'python-dbus: for python-dbus mainloop support'
+ 'qt5-multimedia: QtMultimedia, QtMultimediaWidgets'
+ 'qt5-tools: QtHelp, QtDesigner'
+ 'qt5-svg: QtSvg'
+ 'qt5-webkit: QtWebKit, QtWebKitWidgets'
+ 'qt5-xmlpatterns: QtXmlPatterns'
+ 'qt5-declarative: QtQml, qmlplugin'
+ 'qt5-serialport: QtSerialPort'
+ 'qt5-websockets: QtWebSockets'
+ 'qt5-connectivity: QtNfc, QtBluetooth'
+ 'qt5-x11extras: QtX11Extras'
+ 'qt5-remoteobjects: QtRemoteObjects'
+ 'qt5-speech: QtTextToSpeech'
+ 'qt5-quick3d: QtQuick3D')
+provides=(qt5-python-bindings python-pyqt5)
+makedepends=('sip' 'pyqt-builder' 'python-opengl' 'python-dbus'
+ 'qt5-connectivity' 'qt5-multimedia' 'qt5-tools' 'qt5-serialport' 'qt5-speech' 'qt5-svg'
+ 'qt5-webkit' 'qt5-websockets' 'qt5-x11extras' 'qt5-xmlpatterns' 'qt5-remoteobjects' 'qt5-quick3d')
+conflicts=('pyqt5-common' 'python-pyqt5')
+source=("https://pypi.python.org/packages/source/P/PyQt5/PyQt5-$pkgver.tar.gz"
+ restore-sip4-support.patch)
+sha256sums=('80343bcab95ffba619f2ed2467fd828ffeb0a251ad7225be5fc06dcc333af452'
+ 'c8881a8dc666e509773f93330615d310f9f040c2167dc9e98843741691395f72')
+
+prepare() {
+ patch -d PyQt5-$pkgver -p1 < restore-sip4-support.patch # https://www.riverbankcomputing.com/pipermail/pyqt/2021-November/044346.html
+}
+
+build() {
+ cd PyQt5-$pkgver
+ sip-build \
+ --confirm-license \
+ --no-make \
+ --api-dir /usr/share/qt/qsci/api/python
+ cd build
+ make
+}
+
+package_python-pyqt5-sip4(){
+ cd PyQt5-$pkgver/build
+ make INSTALL_ROOT="$pkgdir" install -j1
+
+ # Remove unused py2 version of uic modules:
+ rm -r "$pkgdir"/usr/lib/python*/site-packages/PyQt5/uic/port_v2
+
+ # compile Python bytecode
+ python -m compileall -d / "$pkgdir"/usr/lib
+ python -O -m compileall -d / "$pkgdir"/usr/lib
+}
diff --git a/restore-sip4-support.patch b/restore-sip4-support.patch
new file mode 100644
index 000000000000..faa3ed4386f9
--- /dev/null
+++ b/restore-sip4-support.patch
@@ -0,0 +1,12 @@
+diff -ru PyQt5-5.15.6.orig/sip/QtCore/QtCoremod.sip PyQt5-5.15.6/sip/QtCore/QtCoremod.sip
+--- PyQt5-5.15.6.orig/sip/QtCore/QtCoremod.sip 2021-11-06 19:41:47.117226645 +0100
++++ PyQt5-5.15.6/sip/QtCore/QtCoremod.sip 2021-11-06 19:42:32.674011854 +0100
+@@ -20,7 +20,7 @@
+ // WARRANTY OF DESIGN, MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.
+
+
+-%Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", use_limited_api=True, py_ssize_t_clean=True)
++%Module(name=PyQt5.QtCore, call_super_init=True, default_VirtualErrorHandler=PyQt5, keyword_arguments="Optional", use_limited_api=True)
+
+ %Timeline {Qt_5_0_0 Qt_5_0_1 Qt_5_0_2 Qt_5_1_0 Qt_5_1_1 Qt_5_2_0 Qt_5_2_1 Qt_5_3_0 Qt_5_3_1 Qt_5_3_2 Qt_5_4_0 Qt_5_4_1 Qt_5_4_2 Qt_5_5_0 Qt_5_5_1 Qt_5_6_0 Qt_5_6_1 Qt_5_6_2 Qt_5_6_3 Qt_5_6_4 Qt_5_6_5 Qt_5_6_6 Qt_5_6_7 Qt_5_6_8 Qt_5_6_9 Qt_5_7_0 Qt_5_7_1 Qt_5_8_0 Qt_5_8_1 Qt_5_9_0 Qt_5_9_1 Qt_5_9_2 Qt_5_9_3 Qt_5_9_4 Qt_5_9_5 Qt_5_9_6 Qt_5_9_7 Qt_5_9_8 Qt_5_9_9 Qt_5_10_0 Qt_5_10_1 Qt_5_11_0 Qt_5_11_1 Qt_5_11_2 Qt_5_11_3 Qt_5_12_0 Qt_5_12_1 Qt_5_12_2 Qt_5_12_3 Qt_5_12_4 Qt_5_13_0 Qt_5_14_0 Qt_5_15_0}
+