summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZen Wen2022-11-22 19:57:53 +0800
committerZen Wen2022-11-22 20:07:22 +0800
commit0a42540a33f04fbc3d5f8b88eb079b392a7c586d (patch)
tree434acd13ed04c4af8ec0daa4439d6dcaaa87958a
parent09edbce3b041f82fb88ca47f0c29efbd8f698471 (diff)
downloadaur-0a42540a33f04fbc3d5f8b88eb079b392a7c586d.tar.gz
Fix the file collision with PyQt5
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6d630d4c92f2..e3e4dc409e9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer:
+# Maintainer: Zen Wen <zen.8841@gmail.com>
pkgname=python-pyqt5-webkit
pkgdesc="Python bindings for the Qt5WebKit"
@@ -34,6 +34,7 @@ package(){
# Remove files provided by pyqt5:
rm -r "$pkgdir"/usr/{bin,share,lib/python*/site-packages/{*.dist-info,PyQt5/{QtCore.*,bindings/QtCore,uic,sip.pyi,py.typed,__init__.py}}}
+ rm "$pkgdir"/usr/lib/python3.10/site-packages/dbus/mainloop/pyqt5.abi3.so
# compile Python bytecode
python -m compileall -d / "$pkgdir"/usr/lib