summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-03-09 17:46:14 -0600
committerLuis Martinez2023-03-09 17:46:14 -0600
commitf0f0ffe687c2049c78d0cf035850920366eded32 (patch)
treeba5a69290f6a018a7fd2ef975d32e2111f15359d
parent88e6c535ce49a6aec1101af61947d149127fb7df (diff)
downloadaur-f0f0ffe687c2049c78d0cf035850920366eded32.tar.gz
update to 2.4
-rw-r--r--.SRCINFO32
-rw-r--r--LICENSE31
-rw-r--r--PKGBUILD51
-rw-r--r--pyrad-2.3.tar.gz.sigbin566 -> 0 bytes
4 files changed, 65 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36795c5b62d6..060450ed0eac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,19 @@
pkgbase = python-pyrad
pkgdesc = Python RADIUS Implementation
- pkgver = 2.3
+ pkgver = 2.4
pkgrel = 1
- url = https://pypi.org/project/pyrad/
+ url = https://github.com/pyradius/pyrad
arch = any
- license = CUSTOM
- makedepends = python
- makedepends = python2
- makedepends = python-setuptools
- makedepends = python2-setuptools
- depends = python
- depends = python2
- source = https://files.pythonhosted.org/packages/source/p/pyrad/pyrad-2.3.tar.gz
- source = pyrad-2.3.tar.gz.sig
- validpgpkeys = 748231EBCBD808A14F5E85D28C004C2F93481F6B
- sha512sums = a3703a6c1cb79735e8c55656e6472461504b4e8cf493caa69cb088e17f8f442184c51123a81ac42a8d94f439bcb164a230da91a377175eb1d35b979055e37359
- sha512sums = SKIP
+ license = BSD
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-poetry
+ makedepends = python-wheel
+ depends = python-netaddr
+ depends = python-six
+ source = python-pyrad-2.4.tar.gz::https://files.pythonhosted.org/packages/source/p/pyrad/pyrad-2.4.tar.gz
+ source = LICENSE
+ sha256sums = 057de4b7e89d8da57ba782c1bde45c63ebee720ae2c0b0a69beaff15c47e30d9
+ sha256sums = 998e0422ba4ca1519d7d61959e00b9eb8377253b00808b3bafdc85628d2be2b8
pkgname = python-pyrad
- depends = python
-
-pkgname = python2-pyrad
- depends = python2
-
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..d68b3a40a7cb
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,31 @@
+Copyright 2020 Istvan Ruzman. All rights reserved.
+Copyright 2017-2020 Christian Giese. All rights reserved.
+Copyright 2007-2008 Simplon. All rights reserved.
+Copyright 2002-2008 Wichert Akkerman. All rights reserved.
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions
+are met:
+1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+3. Neither the name of the University nor the names of its contributors
+ may be used to endorse or promote products derived from this software
+ without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE REGENTS AND CONTRIBUTORS ``AS IS'' AND
+ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
+FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+SUCH DAMAGE.
+
diff --git a/PKGBUILD b/PKGBUILD
index ca0730c6300b..2a192133c8b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,30 @@
-# Maintainer: brent s. <bts[at]square-r00t[dot]net>
-validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: brent s. <bts[at]square-r00t[dot]net>
+
# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
# News updates for packages can be followed at https://devblog.square-r00t.net
-pkgname=('python-pyrad' 'python2-pyrad')
-pkgver=2.3
+pkgname=python-pyrad
+_pkg="${pkgname#python-}"
+pkgver=2.4
pkgrel=1
pkgdesc="Python RADIUS Implementation"
arch=('any')
-url="https://pypi.org/project/pyrad/"
-license=('CUSTOM')
-depends=('python' 'python2')
-makedepends=('python' 'python2' 'python-setuptools' 'python2-setuptools')
-_pkgname=pyrad
-install=
-changelog=
-noextract=()
-source=("https://files.pythonhosted.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
- "${_pkgname}-${pkgver}.tar.gz.sig")
-sha512sums=('a3703a6c1cb79735e8c55656e6472461504b4e8cf493caa69cb088e17f8f442184c51123a81ac42a8d94f439bcb164a230da91a377175eb1d35b979055e37359'
- 'SKIP')
-
-package_python-pyrad() {
- depends=('python')
+url='https://github.com/pyradius/pyrad'
+license=('BSD')
+depends=('python-netaddr' 'python-six')
+makedepends=('python-build' 'python-installer' 'python-poetry' 'python-wheel')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/$_pkg/$_pkg-$pkgver.tar.gz"
+ 'LICENSE')
+sha256sums=('057de4b7e89d8da57ba782c1bde45c63ebee720ae2c0b0a69beaff15c47e30d9'
+ '998e0422ba4ca1519d7d61959e00b9eb8377253b00808b3bafdc85628d2be2b8')
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1
- install -D -m644 ${srcdir}/${_pkgname}-${pkgver}/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
- install -D -m644 ${srcdir}/${_pkgname}-${pkgver}/README.rst ${pkgdir}/usr/share/doc/${pkgname}/README.rst
+build() {
+ cd "$_pkg-$pkgver"
+ python -m build --wheel --no-isolation --skip-dependency-check
}
-package_python2-pyrad() {
- depends=('python2')
-
- cd "${srcdir}/${_pkgname}-${pkgver}"
- python2 setup.py install --root="${pkgdir}" --optimize=1
- install -D -m644 ${srcdir}/${_pkgname}-${pkgver}/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
- install -D -m644 ${srcdir}/${_pkgname}-${pkgver}/README.rst ${pkgdir}/usr/share/doc/${pkgname}/README.rst
+package() {
+ cd "$_pkg-$pkgver"
+ python -m installer --destdir "$pkgdir" dist/*.whl
+ install -Dvm644 "$srcdir/LICENSE" -t "$pkgdir/usr/share/licenses/$pkgname/"
}
diff --git a/pyrad-2.3.tar.gz.sig b/pyrad-2.3.tar.gz.sig
deleted file mode 100644
index 45099a0b7734..000000000000
--- a/pyrad-2.3.tar.gz.sig
+++ /dev/null
Binary files differ