summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjuantascon2017-07-31 15:02:12 -0500
committerjuantascon2017-07-31 15:02:12 -0500
commit18f3d58be2816b84e11fe507e8e289dca512ac49 (patch)
tree4b711d7a813666f1d0ce1a9a2e043015dbfde7d7
downloadaur-18f3d58be2816b84e11fe507e8e289dca512ac49.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dfcb2ebfafa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Jul 31 20:01:46 UTC 2017
+pkgbase = python-pyral
+ pkgdesc = Python Toolkit for Rally
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = https://github.com/RallyTools/RallyRestToolkitForPython
+ arch = any
+ license = PYRAL
+ depends = python
+ depends = python-requests
+ source = https://github.com/RallyTools/RallyRestToolkitForPython/releases/download/v1.3.1/pyral-1.3.1.tar.gz
+ sha256sums = 1f3ee31e78e5a556370c2e1bb950cef57ae7b82033d72ad996f97b149a51e5c7
+
+pkgname = python-pyral
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..07713a5a0a16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: juantascon <juantascon.aur@horlux.org>
+
+pkgname=python-pyral
+_pkgname=pyral
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Python Toolkit for Rally"
+arch=('any')
+url="https://github.com/RallyTools/RallyRestToolkitForPython"
+license=("PYRAL")
+depends=('python' 'python-requests')
+source=("https://github.com/RallyTools/RallyRestToolkitForPython/releases/download/v${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('1f3ee31e78e5a556370c2e1bb950cef57ae7b82033d72ad996f97b149a51e5c7')
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}/
+ python setup.py install --root ${pkgdir}
+}