summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-02-03 12:54:00 -0600
committerLuis Martinez2022-02-03 12:54:00 -0600
commit61049bfe67987b4c164f21b44c33ba0d0ef1c915 (patch)
tree1a26ef2ff9cc2f404f74c7fff26352e91e8a2e67
parent5a21feb9f0e2dfe371212b66ec2a328b40eee239 (diff)
downloadaur-61049bfe67987b4c164f21b44c33ba0d0ef1c915.tar.gz
package cleanup
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD68
2 files changed, 49 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6aebb12874b0..b2d1d7c586be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,28 @@
pkgbase = python-pyramid
- pkgdesc = A very general open source Python web framework.
+ pkgdesc = Open source Python web framework
pkgver = 2.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Pylons/pyramid
arch = any
license = custom:RPL
+ checkdepends = python-pytest
makedepends = python-webtest
makedepends = python-zope-component
makedepends = python-nose
makedepends = python-virtualenv
makedepends = python-repoze.lru
makedepends = python-setuptools
- depends = python-hupper>=1.5
+ makedepends = python-build
+ makedepends = python-install
+ makedepends = python-wheel
+ depends = python-hupper
depends = python-plaster
depends = python-plaster-pastedeploy
- depends = python-translationstring>=0.4
- depends = python-venusian>=1.0
- depends = python-webob>=1.8.3
- depends = python-zope-deprecation>=3.5.0
- depends = python-zope-interface>=3.8.0
+ depends = python-translationstring
+ depends = python-venusian
+ depends = python-webob
+ depends = python-zope-deprecation
+ depends = python-zope-interface
optdepends = python-pyramid-debugtoolbar: development mode
optdepends = python-pastedeploy: pserve/pcreate
optdepends = python-chameleon: pserve/pcreate
diff --git a/PKGBUILD b/PKGBUILD
index 6016788000de..f827b64df39a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,30 +4,36 @@
pkgname=python-pyramid
pkgver=2.0
-pkgrel=2
-pkgdesc='A very general open source Python web framework.'
+pkgrel=3
+pkgdesc='Open source Python web framework'
arch=('any')
url='https://github.com/Pylons/pyramid'
license=('custom:RPL')
-depends=('python-hupper>=1.5'
- 'python-plaster'
- 'python-plaster-pastedeploy'
- 'python-translationstring>=0.4'
- 'python-venusian>=1.0'
- 'python-webob>=1.8.3'
- 'python-zope-deprecation>=3.5.0'
- 'python-zope-interface>=3.8.0')
-makedepends=('python-webtest'
- 'python-zope-component'
- 'python-nose'
- 'python-virtualenv'
- 'python-repoze.lru'
- 'python-setuptools')
-optdepends=('python-pyramid-debugtoolbar: development mode'
- 'python-pastedeploy: pserve/pcreate'
- 'python-chameleon: pserve/pcreate'
- 'python-waitress: pserve/pcreate')
-
+depends=(
+ 'python-hupper'
+ 'python-plaster'
+ 'python-plaster-pastedeploy'
+ 'python-translationstring'
+ 'python-venusian'
+ 'python-webob'
+ 'python-zope-deprecation'
+ 'python-zope-interface')
+makedepends=(
+ 'python-webtest'
+ 'python-zope-component'
+ 'python-nose'
+ 'python-virtualenv'
+ 'python-repoze.lru'
+ 'python-setuptools'
+ 'python-build'
+ 'python-install'
+ 'python-wheel')
+optdepends=(
+ 'python-pyramid-debugtoolbar: development mode'
+ 'python-pastedeploy: pserve/pcreate'
+ 'python-chameleon: pserve/pcreate'
+ 'python-waitress: pserve/pcreate')
+checkdepends=('python-pytest')
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/p/pyramid/pyramid-$pkgver.tar.gz"
"$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/source/p/pyramid/pyramid-$pkgver.tar.gz.asc")
sha256sums=('45431b387587ed0fac6213b54d6e9f0936f0cc85238a8f5af7852fc9484c5c77'
@@ -35,20 +41,20 @@ sha256sums=('45431b387587ed0fac6213b54d6e9f0936f0cc85238a8f5af7852fc9484c5c77'
validpgpkeys=('CC1A48C957AC6ABEF05B2C596BC977B056B829E5')
build() {
- cd pyramid-$pkgver
- python setup.py build
+ cd "pyramid-$pkgver"
+ python -m build --wheel --skip-dependency-check --no-isolation
}
-# check() {
-# cd pyramid-$pkgver
-# # this fails because testing can be done only once pyramid is installed...
-# # nosetests
-# }
+check() {
+ cd "pyramid-$pkgver"
+ PYTHONPATH=./src pytest -x --disable-warnings
+}
package() {
- cd pyramid-$pkgver
- python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
- install -Dm 644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
+ export PYTHONHASHSEED=0
+ cd "pyramid-$pkgver"
+ python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et: