summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-07-15 03:13:22 -0500
committerLuis Martinez2021-07-15 03:13:22 -0500
commitef6164e6c55877e0cf2022d65cf272ad314dc81a (patch)
treeb72d185219a161b05d2a38849ed0b2fa9729e01a
parent7a3e3728c322fb13408aeaa4e4249c86c54be703 (diff)
downloadaur-ef6164e6c55877e0cf2022d65cf272ad314dc81a.tar.gz
update to 2.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5effa9d7d44a..109d6ad940ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyramid
pkgdesc = A very general open source Python web framework.
- pkgver = 1.10.5
+ pkgver = 2.0
pkgrel = 1
url = https://github.com/Pylons/pyramid
arch = any
@@ -11,20 +11,19 @@ pkgbase = python-pyramid
makedepends = python-virtualenv
makedepends = python-repoze.lru
makedepends = python-setuptools
- depends = python-hupper
+ depends = python-hupper>=1.5
depends = python-plaster
depends = python-plaster-pastedeploy
- depends = python-translationstring
- depends = python-venusian
- depends = python-webob
- depends = python-zope-deprecation
- depends = python-zope-interface
+ depends = python-translationstring>=0.4
+ depends = python-venusian>=1.0
+ depends = python-webob>=1.8.3
+ depends = python-zope-deprecation>=3.5.0
+ depends = python-zope-interface>=3.8.0
optdepends = python-pyramid-debugtoolbar: development mode
optdepends = python-pastedeploy: pserve/pcreate
optdepends = python-chameleon: pserve/pcreate
optdepends = python-waitress: pserve/pcreate
- source = https://github.com/Pylons/pyramid/archive/1.10.5.tar.gz
- sha256sums = ad3f8d4ca1342e4b8c4a28a08144fea4cbc31457a78604ae3d0ac9f30e62dd07
+ source = python-pyramid-2.0.tar.gz::https://github.com/Pylons/pyramid/archive/2.0.tar.gz
+ sha256sums = 352f4a2b112084dccaafe6d5189ebc43616a4de04d03e2465b31dc22f8666439
pkgname = python-pyramid
-
diff --git a/PKGBUILD b/PKGBUILD
index 217597a1233e..6c6f6520e64d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
# Contributor: Sergey Mastykov <smastykov at gmail dot com>
pkgname=python-pyramid
-pkgver=1.10.5
+pkgver=2.0
pkgrel=1
pkgdesc='A very general open source Python web framework.'
arch=('any')
url='https://github.com/Pylons/pyramid'
license=('custom')
-depends=('python-hupper'
+depends=('python-hupper>=1.5'
'python-plaster'
'python-plaster-pastedeploy'
- 'python-translationstring'
- 'python-venusian'
- 'python-webob'
- 'python-zope-deprecation'
- 'python-zope-interface')
+ 'python-translationstring>=0.4'
+ 'python-venusian>=1.0'
+ 'python-webob>=1.8.3'
+ 'python-zope-deprecation>=3.5.0'
+ 'python-zope-interface>=3.8.0')
makedepends=('python-webtest'
'python-zope-component'
'python-nose'
@@ -27,8 +27,8 @@ optdepends=('python-pyramid-debugtoolbar: development mode'
'python-chameleon: pserve/pcreate'
'python-waitress: pserve/pcreate')
-source=($url/archive/${pkgver}.tar.gz)
-sha256sums=('ad3f8d4ca1342e4b8c4a28a08144fea4cbc31457a78604ae3d0ac9f30e62dd07')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('352f4a2b112084dccaafe6d5189ebc43616a4de04d03e2465b31dc22f8666439')
build() {
cd pyramid-$pkgver
@@ -38,7 +38,7 @@ build() {
check() {
cd pyramid-$pkgver
# this fails because testing can be done only once pyramid is installed...
- # nosetests
+ # nosetests
}
package() {