summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2020-02-05 16:57:09 +0100
committerPhilipp A2020-02-05 16:57:09 +0100
commit2e123d3705b6b9c6cd30d23a1dde3b058c4aa412 (patch)
treec914a2e1dbd244abf9871e96fb227cd5227dd724
downloadaur-2e123d3705b6b9c6cd30d23a1dde3b058c4aa412.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b58b9279666
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pyreadr
+ pkgdesc = Read and write R RData and Rds files into/from pandas dataframes.
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/ofajardo/pyreadr
+ arch = x86_64
+ license = AGPL
+ depends = python-pandas
+ noextract = pyreadr-0.2.3-cp38-cp38-manylinux1_x86_64.whl
+ source = https://files.pythonhosted.org/packages/cp38/p/pyreadr/pyreadr-0.2.3-cp38-cp38-manylinux1_x86_64.whl
+ sha256sums = 519ea1a9d5760cf29b8d0247132104520042aaf8c4b515095ab4d66daa20fe2e
+
+pkgname = python-pyreadr
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4d7ad300862e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.whl
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97fcbe002296
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_name=pyreadr
+pkgname=python-$_name
+pkgver=0.2.3
+pkgrel=1
+pkgdesc='Read and write R RData and Rds files into/from pandas dataframes.'
+arch=(x86_64)
+url="https://github.com/ofajardo/$_name"
+license=(AGPL)
+depends=(python-pandas)
+_wheel="${_name/-/_}-$pkgver-cp38-cp38-manylinux1_$CARCH.whl"
+source=("https://files.pythonhosted.org/packages/cp38/${_name::1}/$_name/$_wheel")
+sha256sums=('519ea1a9d5760cf29b8d0247132104520042aaf8c4b515095ab4d66daa20fe2e')
+noextract=("$_wheel")
+
+package() {
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
+}