summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authora8212023-05-03 16:33:41 +0200
committera8212023-05-03 16:33:41 +0200
commita15ca823b27eead7e70ebf85ff78f8b04a68362c (patch)
treedf614879feec141ff6629c0cea9485f5445bf201
parent947e481d6d2d4e2bfcb7bb5874fa44f64a3e22be (diff)
downloadaur-a15ca823b27eead7e70ebf85ff78f8b04a68362c.tar.gz
bump for python 3.11
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e24f9494a8e..5938c10c4254 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = python-pyreadr
pkgdesc = Reads/writes R RData and Rds files into/from pandas data frames
pkgver = 0.4.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ofajardo/pyreadr
arch = x86_64
license = AGPL3
checkdepends = python-xarray
makedepends = cython
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = bzip2
depends = python-pandas
depends = xz
diff --git a/PKGBUILD b/PKGBUILD
index c4cec9376b26..010aa30836df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=python-pyreadr
_name=${pkgname#python-}
pkgver=0.4.7
-pkgrel=1
+pkgrel=2
pkgdesc='Reads/writes R RData and Rds files into/from pandas data frames'
arch=('x86_64')
url="https://github.com/ofajardo/pyreadr"
license=('AGPL3')
depends=('bzip2' 'python-pandas' 'xz' 'zlib')
-makedepends=('cython')
+makedepends=('cython' 'python-build' 'python-installer' 'python-wheel')
checkdepends=('python-xarray')
optdepends=('python-xarray: for 3D array support')
source=("$_name-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
@@ -17,18 +17,18 @@ sha256sums=('7f14db1022030b2751cfbace6f1a16e6ff738ffc150360d694924e8278b9f60d')
build() {
cd "${_name}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd "${_name}-${pkgver}"
- python setup.py build_ext --inplace
- python tests/test_basic.py --inplace
+ local _pyver=$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')
+ PYTHONPATH="$PWD/build/lib.linux-x86_64-cpython-$_pyver" python tests/test_basic.py
}
package() {
cd "${_name}-${pkgver}"
- python setup.py install --root "${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
# vim: set ts=4 sw=4 et: