summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Orru2019-04-24 00:30:31 +0200
committerAndrea Orru2019-04-24 00:30:31 +0200
commitb8916a8e2015720c5ecc9abcdd3c37895edb78e7 (patch)
treea27848d4658ef9b960b92ea997b088edcda5e21e
downloadaur-b8916a8e2015720c5ecc9abcdd3c37895edb78e7.tar.gz
Initial revision
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD18
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5b734b4afa4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pyrepl
+ pkgdesc = A library for building flexible command line interfaces
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = http://bitbucket.org/pypy/pyrepl/
+ arch = any
+ license = MIT
+ license = X11
+ license = style
+ makedepends = python
+ makedepends = python-pip
+
+pkgname = python-pyrepl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11efb167d300
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# PKGBUILD generated by pipman
+# Python package author: Michael Hudson-Doyle <micahel@gmail.com>
+pkgname=python-pyrepl
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="A library for building flexible command line interfaces"
+arch=(any)
+url="http://bitbucket.org/pypy/pyrepl/"
+license=(MIT X11 style)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="pyrepl" pyrepl==0.9.0
+}
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p $pkgdir/"$sitepackages"
+ cp -r $srcdir/pyrepl/* $pkgdir/"$sitepackages"
+} \ No newline at end of file