summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Lui Geh2020-01-29 15:07:19 -0300
committerRenato Lui Geh2020-01-29 15:07:19 -0300
commite8884a1552860300335c31e94bbb879eb757c568 (patch)
tree5cb23228e9a49c5b2aa5caa4c58c37454a6371a9
downloadaur-e8884a1552860300335c31e94bbb879eb757c568.tar.gz
Create PKGBUILD
Signed-off-by: Renato Lui Geh <renatogeh@gmail.com>
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD26
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..261bf8eceeaa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-pyro-api
+ pkgdesc = Generic API for dispatch to Pyro backends.
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = http://pyro.ai/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ optdepends = flake8
+ optdepends = python-sphinx
+ optdepends = python-sphinx_rtd_theme
+ optdepends = python-pytest
+ optdepends = ipython
+ source = https://files.pythonhosted.org/packages/ea/33/74c3b62306a0c496208038a7f573d4dbe12f74c1db91ca96b5a055020bb9/pyro-api-0.1.1.tar.gz
+ sha256sums = bf3942773a9982908e907d2bbc70a27bd3f5bc3eb7c7b6a8db5bb81bcc3d0d66
+
+pkgname = python-pyro-api
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..42ff89997f17
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+clean.sh
+instructions.txt
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a3a9fa6f5e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Renato Lui Geh <renatogeh at gmail dot com>
+
+pkgname=python-pyro-api
+_pypiname=${pkgname/python-/}
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Generic API for dispatch to Pyro backends."
+arch=('any')
+url="http://pyro.ai/"
+license=('MIT')
+depends=('python')
+optdepends=('flake8' 'python-sphinx' 'python-sphinx_rtd_theme' 'python-pytest' 'ipython')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/ea/33/74c3b62306a0c496208038a7f573d4dbe12f74c1db91ca96b5a055020bb9/${_pypiname}-${pkgver}.tar.gz")
+sha256sums=('bf3942773a9982908e907d2bbc70a27bd3f5bc3eb7c7b6a8db5bb81bcc3d0d66')
+
+build() {
+ cd $srcdir/${_pypiname}-${pkgver}
+ python3 setup.py build
+}
+
+package() {
+ cd $srcdir/${_pypiname}-${pkgver}
+ python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+