summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Lui Geh2022-03-28 14:45:15 -0300
committerRenato Lui Geh2022-03-28 14:45:15 -0300
commit842db30162da526bee4566fe9505d7011dbedacb (patch)
tree56304afad13266d269578c5b7dc75ef04d5c0385
parentc6694958aa3e2fd84bfaf0b989905e5be925093a (diff)
downloadaur-842db30162da526bee4566fe9505d7011dbedacb.tar.gz
Set cuda as optional, bump to 1.8.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30cd02518565..f85f388954d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyro-ppl
pkgdesc = A Python library for probabilistic modeling and inference
- pkgver = 1.8.0
+ pkgver = 1.8.1
pkgrel = 1
url = http://pyro.ai/
arch = any
@@ -14,8 +14,9 @@ pkgbase = python-pyro-ppl
depends = python-numpy
depends = python-opt_einsum
depends = python-pyro-api
- depends = python-pytorch-cuda
+ depends = python-pytorch
depends = python-tqdm
+ optdepends = python-pytorch-cuda
optdepends = flake8
optdepends = python-isort
optdepends = jupyter-nbformat
@@ -39,7 +40,7 @@ pkgbase = python-pyro-ppl
optdepends = python-prettytable
optdepends = python-pytest-benchmark
optdepends = python-snakeviz
- source = https://files.pythonhosted.org/packages/4c/bd/658eaf515f65905f1e63364917e98ce50bb3e53c8c6c125eea0e015206ee/pyro-ppl-1.8.0.tar.gz
- sha256sums = 68e4ea30f219227dd88e55de2550d3f8c20a20adbdb67ad1e13b50868bb2ac0c
+ source = https://files.pythonhosted.org/packages/31/0a/b27ef924616b79568199f36a15200c60e45b6fb6d8b684d4aaece5e290dd/pyro-ppl-1.8.1.tar.gz
+ sha256sums = d7c049eb2e7485a612b4dd99c24c309cc860c7cbc6b1973387034f5436d1c8d6
pkgname = python-pyro-ppl
diff --git a/PKGBUILD b/PKGBUILD
index 7efbc3f57407..5d05b9167988 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
pkgname=python-pyro-ppl
_pypiname=${pkgname/python-/}
-pkgver=1.8.0
+pkgver=1.8.1
pkgrel=1
pkgdesc="A Python library for probabilistic modeling and inference"
arch=('any')
url="http://pyro.ai/"
license=('Apache 2.0')
-depends=('python' 'python-numpy' 'python-opt_einsum' 'python-pyro-api' 'python-pytorch-cuda'
+depends=('python' 'python-numpy' 'python-opt_einsum' 'python-pyro-api' 'python-pytorch'
'python-tqdm')
-optdepends=('flake8' 'python-isort' 'jupyter-nbformat' 'python-nbsphinx' 'python-nbstripout'
+optdepends=('python-pytorch-cuda' 'flake8' 'python-isort' 'jupyter-nbformat' 'python-nbsphinx' 'python-nbstripout'
'ninja' 'python-pypandoc' 'python-pytest-xdist' 'jupyter' 'graphviz' 'python-matplotlib'
'python-sphinx' 'python-sphinx_rtd_theme' 'yapf' 'python-pillow-simd' 'python-torchvision'
'python-visdom' 'python-pandas' 'python-seaborn' 'python-wget' 'python-prettytable'
'python-pytest-benchmark' 'python-snakeviz')
checkdepends=('python-nbval' 'python-pytest-cov' 'python-pytest' 'python-scipy')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/4c/bd/658eaf515f65905f1e63364917e98ce50bb3e53c8c6c125eea0e015206ee/${_pypiname}-${pkgver}.tar.gz")
-sha256sums=('68e4ea30f219227dd88e55de2550d3f8c20a20adbdb67ad1e13b50868bb2ac0c')
+source=("https://files.pythonhosted.org/packages/31/0a/b27ef924616b79568199f36a15200c60e45b6fb6d8b684d4aaece5e290dd/${_pypiname}-${pkgver}.tar.gz")
+sha256sums=('d7c049eb2e7485a612b4dd99c24c309cc860c7cbc6b1973387034f5436d1c8d6')
build() {
cd $srcdir/${_pypiname}-${pkgver}