summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Warrick2014-12-31 11:02:23 +0100
committerChris Warrick2014-12-31 11:02:23 +0100
commit6ff617e5feed4f8d76fb0571871d4253037c1480 (patch)
tree8a3bca538c3a69f0f0aaa4cf7a0ccfe0a2e39563
downloadaur-6ff617e5feed4f8d76fb0571871d4253037c1480.tar.gz
init python-pyroma
Signed-off-by: Chris Warrick <kwpolska@gmail.com>
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b823180c310
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pyroma
+ pkgdesc = Test your project's packaging friendliness
+ pkgver = 1.7
+ pkgrel = 1
+ url = https://bitbucket.org/regebro/pyroma
+ arch = any
+ license = MIT
+ makedepends = python-distribute
+ depends = python
+ depends = python-docutils
+ options = !emptydirs
+ source = http://pypi.python.org/packages/source/p/pyroma/pyroma-1.7.zip
+ md5sums = 436b1401c5d4a9c7d307336128ccfd30
+
+pkgname = python-pyroma
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfb28594e555
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Chris Warrick <aur@chriswarrick.com>
+pkgname=python-pyroma
+_pyname=pyroma
+pkgver=1.7
+pkgrel=1
+pkgdesc="Test your project's packaging friendliness"
+arch=('any')
+url='https://bitbucket.org/regebro/pyroma'
+license=('MIT')
+depends=('python' 'python-docutils')
+makedepends=('python-distribute')
+options=(!emptydirs)
+source=("http://pypi.python.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.zip")
+md5sums=('436b1401c5d4a9c7d307336128ccfd30')
+
+package() {
+ cd "${srcdir}/${_pyname}-${pkgver}"
+ python3 setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: