summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Ellison2015-12-10 23:11:47 -0500
committerMatthew Ellison2015-12-10 23:11:47 -0500
commit6c2e5b17b59a9950321066426688e391b665a041 (patch)
treee082529b45678d22f0b99c725d433b5e52566fb8
downloadaur-6c2e5b17b59a9950321066426688e391b665a041.tar.gz
Initial Package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b0339644b69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Dec 11 04:10:41 UTC 2015
+pkgbase = python-pyroute2
+ pkgdesc = A pure Python netlink and Linux network configuration library.
+ pkgver = 0.3.15
+ pkgrel = 1
+ url = http://docs.pyroute2.org/
+ arch = any
+ license = GPL2
+ license = Apache
+ makedepends = python
+ makedepends = python-setuptools
+ source = https://pypi.python.org/packages/source/p/pyroute2/pyroute2-0.3.15.tar.gz
+ sha256sums = f5b7116fd97f73f97adc3b9c040a4ddbe61f18bb02f47e1c8399567c8791d270
+
+pkgname = python-pyroute2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f240c7505daf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Matthew Ellison <matt+aur@arroyonetworks.com>
+
+_pkgname='pyroute2'
+pkgname="python-${_pkgname}"
+pkgver=0.3.15
+pkgrel=1
+pkgdesc='A pure Python netlink and Linux network configuration library.'
+arch=('any')
+url='http://docs.pyroute2.org/'
+license=('GPL2' 'Apache')
+depends=()
+makedepends=('python' 'python-setuptools')
+source=("https://pypi.python.org/packages/source/p/pyroute2/pyroute2-${pkgver}.tar.gz")
+sha256sums=('f5b7116fd97f73f97adc3b9c040a4ddbe61f18bb02f47e1c8399567c8791d270')
+
+check() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py check
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root "${pkgdir}" --optimize=1
+}