summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2022-09-10 23:01:45 +0700
committerAchmad Fathoni2022-09-10 23:01:45 +0700
commit641b69a52367f0fe96f34a2c282df5167618df25 (patch)
treedd0c05d15c6d00a700a080ccf2f78c291a605c63
downloadaur-641b69a52367f0fe96f34a2c282df5167618df25.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26a2ef295d61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pyrtcm
+ pkgdesc = RTCM3 Protocol Parser
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/semuconsulting/pyrtcm
+ arch = any
+ license = BSD
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/p/pyrtcm/pyrtcm-0.3.0.tar.gz
+ sha256sums = 2f2e1de15e3e279402a1a5cdf69f34407f6758ec45cffced29e504e982f2f7c3
+
+pkgname = python-pyrtcm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d17ff63b0fec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgbase=python-pyrtcm
+pkgname=python-pyrtcm
+_module='pyrtcm'
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="RTCM3 Protocol Parser"
+url="https://github.com/semuconsulting/pyrtcm"
+depends=('python')
+makedepends=(python-build python-installer python-wheel python-setuptools)
+license=('BSD')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('2f2e1de15e3e279402a1a5cdf69f34407f6758ec45cffced29e504e982f2f7c3')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}