summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2021-11-24 16:00:52 +0800
committerPumpkinCheshire2021-11-24 16:00:52 +0800
commit6d583b378ca348bfea026dd18bf4b1e6669647d0 (patch)
tree7b8e4c0719dba29331493ad0305075fa1d3816c4
parent1321d9589457ac1e974c9d4dc9146c1c36a12680 (diff)
downloadaur-6d583b378ca348bfea026dd18bf4b1e6669647d0.tar.gz
bump to 0.18.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3b276073838..a086269e606c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pysam
pkgdesc = Python interface for the SAM/BAM sequence alignment and mapping format
- pkgver = 0.17.0
+ pkgver = 0.18.0
pkgrel = 1
url = https://github.com/pysam-developers/pysam
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = python-pysam
depends = python
provides = python-pysam
options = !emptydirs
- source = https://github.com/pysam-developers/pysam/archive/v0.17.0.tar.gz
- sha256sums = f4d697e322d12f239c96c263374bad2b40fd95bff34841ab9515e3de9e3e7cca
+ source = https://github.com/pysam-developers/pysam/archive/v0.18.0.tar.gz
+ b2sums = bc38e5dc0c7714001ead895d01e18063fedb2da5c4c1d907c0d832da19924f5c7a3c65bf85e7148cbc0c3f37317a56e82e06bc7850c11d971bd22757433b74f5
pkgname = python-pysam
diff --git a/PKGBUILD b/PKGBUILD
index e8c9bafd8b98..ba242737bcfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
#!/bin/bash
-# Maintainer: PumpkinCheshire <sollyonzou at gmail dot com>
+# Maintainer: PumpkinCheshire <me at pumpkincheshire dot com>
# Contributor: Fabio Zanini <fabio.zanini _at_ stanford.edu>
pkgname=python-pysam
_name=pysam
-pkgver=0.17.0
+pkgver=0.18.0
pkgrel=1
pkgdesc='Python interface for the SAM/BAM sequence alignment and mapping format'
arch=('x86_64')
url="https://github.com/pysam-developers/pysam"
license=('MIT')
depends=('python')
-makedepends=('python-setuptools' 'cython' 'htslib')
+makedepends=(
+ 'python-setuptools'
+ 'cython'
+ 'htslib'
+)
provides=('python-pysam')
options=(!emptydirs)
source=("https://github.com/pysam-developers/${_name}/archive/v${pkgver}.tar.gz")
-sha256sums=('f4d697e322d12f239c96c263374bad2b40fd95bff34841ab9515e3de9e3e7cca')
+b2sums=('bc38e5dc0c7714001ead895d01e18063fedb2da5c4c1d907c0d832da19924f5c7a3c65bf85e7148cbc0c3f37317a56e82e06bc7850c11d971bd22757433b74f5')
build() {
cd "$srcdir/$_name-$pkgver"