summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Zanini2016-05-05 00:41:36 +0200
committerFabio Zanini2016-05-05 00:41:36 +0200
commit94cca06cde6d627911b0044a1cdf9f8170e41d54 (patch)
tree12beebb0a30eb2926c279c52f11fabcc17365b17
parent6a9eb2db6c37201a91cfc3902990c92d4c4e5075 (diff)
downloadaur-94cca06cde6d627911b0044a1cdf9f8170e41d54.tar.gz
0.9.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6331714ecc06..dafd17b21dcd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pysam
pkgdesc = Python interface for the SAM/BAM sequence alignment and mapping format
- pkgver = 0.8.4
+ pkgver = 0.9.0
pkgrel = 1
url = https://github.com/pysam-developers/pysam
arch = x86_64
@@ -10,8 +10,8 @@ pkgbase = python-pysam
depends = python
provides = python-pysam
options = !emptydirs
- source = https://github.com/pysam-developers/pysam/archive/v0.8.4.tar.gz
- md5sums = 66bc07593fe420ec415ef24d8b36e996
+ source = https://github.com/pysam-developers/pysam/archive/v0.9.0.tar.gz
+ md5sums = 4c80bc1612e18c0d9027b9f000fd38f1
pkgname = python-pysam
diff --git a/PKGBUILD b/PKGBUILD
index 8ec97a4efdb9..a5b38516c61a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Fabio Zanini <fabio.zanini _at_ tuebingen.mpg.de>
pkgname='python-pysam'
-pkgver=0.8.4
+pkgver=0.9.0
pkgrel=1
pkgdesc="Python interface for the SAM/BAM sequence alignment and mapping format"
arch=('x86_64')
@@ -16,11 +16,14 @@ backup=()
options=(!emptydirs)
install=
source=("https://github.com/pysam-developers/pysam/archive/v${pkgver}.tar.gz")
-md5sums=('66bc07593fe420ec415ef24d8b36e996')
+md5sums=('4c80bc1612e18c0d9027b9f000fd38f1')
package() {
cd "$srcdir/pysam-$pkgver"
+ # Use following line instead to compile with the internal htslib
python setup.py install --root="$pkgdir/" --optimize=1
+ # Use the following line to compile against external htslib from AUR (buggy)
+ #HTSLIB_LIBRARY_DIR=/usr/lib HTSLIB_INCLUDE_DIR=/usr/include python setup.py install --root="$pkgdir/" --optimize=1
}
# vim:set ts=2 sw=2 et: