summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Zanini2015-06-18 12:05:07 +0200
committerFabio Zanini2015-06-18 12:05:07 +0200
commitc7b0788d5fcfe51735712fb0a28014b6bf2befeb (patch)
tree74b7d367dd42b708de931caf25cc7f133a105b4a
downloadaur-c7b0788d5fcfe51735712fb0a28014b6bf2befeb.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8827943f7d60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pysam
+ pkgdesc = Python interface for the SAM/BAM sequence alignment and mapping format
+ pkgver = 0.8.3
+ pkgrel = 1
+ url = https://github.com/pysam-developers/pysam
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = cython>=0.22
+ depends = python
+ provides = python-pysam
+ options = !emptydirs
+ source = https://github.com/pysam-developers/pysam/archive/v0.8.3.tar.gz
+ md5sums = 5ea56c66c3890fef2dc31fc005182f72
+
+pkgname = python-pysam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73af7bd8d68e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Fabio Zanini <fabio.zanini _at_ tuebingen.mpg.de>
+pkgname='python-pysam'
+pkgver=0.8.3
+pkgrel=1
+pkgdesc="Python interface for the SAM/BAM sequence alignment and mapping format"
+arch=('x86_64')
+url="https://github.com/pysam-developers/pysam"
+license=('MIT')
+groups=()
+depends=('python')
+makedepends=('python-setuptools' 'cython>=0.22')
+provides=('python-pysam')
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://github.com/pysam-developers/pysam/archive/v${pkgver}.tar.gz")
+md5sums=('5ea56c66c3890fef2dc31fc005182f72')
+
+package() {
+ cd "$srcdir/pysam-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: