summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2022-07-20 12:48:55 -0500
committerLuis Martinez2022-07-20 12:48:55 -0500
commit06afb322ad74faa990d942c6ee9b4ecc9f07f1e4 (patch)
tree0be40d97b2700a7020583dfeb1d19e86f0121387
parent19136f81003e30272dc6a34f7c891b96ed99dad8 (diff)
downloadaur-06afb322ad74faa990d942c6ee9b4ecc9f07f1e4.tar.gz
update to 4.3
-rw-r--r--.SRCINFO18
-rw-r--r--CHANGELOG.rst21
-rw-r--r--PKGBUILD17
3 files changed, 34 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f85df705f9b9..249af2fe81c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,29 @@
pkgbase = python-pyscaffold
pkgdesc = Python project template generator with batteries included
- pkgver = 4.2.3
+ pkgver = 4.3
pkgrel = 1
url = https://github.com/pyscaffold/pyscaffold
changelog = CHANGELOG.rst
arch = any
license = MIT
- makedepends = python-setuptools
- makedepends = python-setuptools-scm
makedepends = python-build
makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-setuptools-scm
makedepends = python-wheel
depends = python-appdirs
depends = python-configupdater
depends = python-packaging
depends = python-platformdirs
depends = python-tomlkit
- optdepends = python-django: Scaffold Django projects.
optdepends = python-cookiecutter: Create custom scaffold templates.
+ optdepends = python-django: Scaffold Django projects.
optdepends = python-pre-commit: Use Git pre-commit hooks.
- optdepends = python-sphinx: Support building documentation with Sphinx.
- optdepends = python-pytest: Use the integrated unit testing.
- optdepends = python-pytest-runner: Use the integrated unit testing.
optdepends = python-pytest-cov: Generate a coverage report for your project.
- source = python-pyscaffold-4.2.3.tar.gz::https://files.pythonhosted.org/packages/source/P/PyScaffold/PyScaffold-4.2.3.tar.gz
- sha256sums = 58c7d9ce296cc26ac377061365c2f87cd8e28f46e4fb2c96ee48f9c64e33ac4a
+ optdepends = python-pytest-runner: Use the integrated unit testing.
+ optdepends = python-pytest: Use the integrated unit testing.
+ optdepends = python-sphinx: Support building documentation with Sphinx.
+ source = python-pyscaffold-4.3.tar.gz::https://files.pythonhosted.org/packages/source/P/PyScaffold/PyScaffold-4.3.tar.gz
+ sha256sums = 1a8c39bbad9abc121d6e126035740ba5f043434abb432f368a3a76596184b3ed
pkgname = python-pyscaffold
diff --git a/CHANGELOG.rst b/CHANGELOG.rst
index 609afa780b54..996e801cb772 100644
--- a/CHANGELOG.rst
+++ b/CHANGELOG.rst
@@ -13,16 +13,29 @@ Changelog
Current versions
================
-Version 4.2.2, 2022-05-26
--------------------------
+Version 4.3, 2022-07-20
+-----------------------
-- Update ``.github/workflows/ci.yml`` template, :pr:`637` and :pr:`640`
-- Update note in ``skeleton.py`` template clarifying file can be renamed, :pr:`641`
+- Removed ``wheel`` from the set of build dependencies in ``pyproject.toml``
+ (it is redundant since ``setuptools`` already includes it), :pr:`652`.
+- Updated ``freebsd`` configuration in ``.cirrus.yml`` (with workaround for
+ ``pipx`` in 2022Q3 repo), :pr:`657`.
Older versions
==============
+Version 4.2.3, 2022-06-17
+-------------------------
+
+- Automatically create directory when saving config file, :issue:`648`
+
+Version 4.2.2, 2022-05-26
+-------------------------
+
+- Update ``.github/workflows/ci.yml`` template, :pr:`637` and :pr:`640`
+- Update note in ``skeleton.py`` template clarifying file can be renamed, :pr:`641`
+
Version 4.2.1, 2022-03-16
-------------------------
diff --git a/PKGBUILD b/PKGBUILD
index 3f5c84ea2e6a..9bcbe74b5e03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-pyscaffold
_pkg=PyScaffold
-pkgver=4.2.3
+pkgver=4.3
pkgrel=1
pkgdesc="Python project template generator with batteries included"
url="https://github.com/pyscaffold/pyscaffold"
@@ -16,23 +16,23 @@ depends=(
'python-platformdirs'
'python-tomlkit')
optdepends=(
- 'python-django: Scaffold Django projects.'
'python-cookiecutter: Create custom scaffold templates.'
+ 'python-django: Scaffold Django projects.'
'python-pre-commit: Use Git pre-commit hooks.'
- 'python-sphinx: Support building documentation with Sphinx.'
- 'python-pytest: Use the integrated unit testing.'
+ 'python-pytest-cov: Generate a coverage report for your project.'
'python-pytest-runner: Use the integrated unit testing.'
- 'python-pytest-cov: Generate a coverage report for your project.')
+ 'python-pytest: Use the integrated unit testing.'
+ 'python-sphinx: Support building documentation with Sphinx.')
makedepends=(
- 'python-setuptools'
- 'python-setuptools-scm'
'python-build'
'python-installer'
+ 'python-setuptools'
+ 'python-setuptools-scm'
'python-wheel')
# checkdepends=('python-pytest' 'python-pytest-virtualenv')
changelog=CHANGELOG.rst
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/${_pkg::1}/$_pkg/$_pkg-$pkgver.tar.gz")
-sha256sums=('58c7d9ce296cc26ac377061365c2f87cd8e28f46e4fb2c96ee48f9c64e33ac4a')
+sha256sums=('1a8c39bbad9abc121d6e126035740ba5f043434abb432f368a3a76596184b3ed')
build() {
cd "$_pkg-$pkgver"
@@ -52,7 +52,6 @@ build() {
package() {
cd "$_pkg-$pkgver"
PYTHONHASHSEED=0 python -m installer --destdir="$pkgdir/" dist/*.whl
-
local _site="$(python -c 'import site; print(site.getsitepackages()[0])')"
install -d "$pkgdir/usr/share/licenses/$pkgname/"
ln -s \