summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgkmcd2018-09-23 10:50:09 +1000
committergkmcd2018-09-23 10:50:09 +1000
commitc1999a2d978c6eb2a0e8e0326f60a46695a24cc9 (patch)
tree41310efcdcb9ab0b521745c7a0bd95ae6fd49099
parent7ce68d88936e9b622ddb329b439ff13fb09606e5 (diff)
downloadaur-c1999a2d978c6eb2a0e8e0326f60a46695a24cc9.tar.gz
fix makedepends, fix and install licence
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1877114ddf02..0b1c149cef32 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,9 +4,9 @@ pkgbase = python-pyscaffold
pkgrel = 1
url = https://pyscaffold.org/
arch = any
- license = BSD
+ license = MIT
+ makedepends = git
makedepends = python-setuptools-scm
- makedepends = python-pbr
makedepends = python-wheel
depends = python
optdepends = python-django: scaffold django projects
@@ -15,6 +15,4 @@ pkgbase = python-pyscaffold
md5sums = SKIP
pkgname = python-pyscaffold
- depends = python-pbr
- depends = python-wheel
diff --git a/PKGBUILD b/PKGBUILD
index 9a9967cbc67f..c445dfb19c6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,12 @@ pkgrel=1
pkgdesc="Python project template generator with batteries included"
url="https://pyscaffold.org/"
arch=(any)
-license=('BSD')
+license=('MIT')
depends=('python')
optdepends=('python-django: scaffold django projects'
'python-cookiecutter: create custom scaffold templates')
-makedepends=('python-setuptools-scm' 'python-pbr' 'python-wheel')
+# makedepends=('python-setuptools-scm' 'python-pbr' 'python-wheel')
+makedepends=('git' 'python-setuptools-scm' 'python-wheel')
source=("pyscaffold-${pkgver}::git+https://github.com/blue-yonder/pyscaffold.git#tag=v${pkgver}")
md5sums=('SKIP')
@@ -20,9 +21,7 @@ build() {
}
package_python-pyscaffold() {
- depends=('python-pbr' 'python-wheel')
-
cd "${srcdir}/pyscaffold-$pkgver"
python setup.py install --root=${pkgdir}
- #rm -r ${pkgdir}/usr/share/pyscaffold/docs
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}