summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgkmcd2018-09-25 18:31:37 +1000
committergkmcd2018-09-25 18:31:37 +1000
commitc53044b410cfb93e787242607f329b5c3c748d17 (patch)
tree11ddb564529a794827c07a13fef0ab5d62efe586
parenta39f48a8cef0df517756d76c11016880bcf95549 (diff)
downloadaur-c53044b410cfb93e787242607f329b5c3c748d17.tar.gz
update optdepends to better reflect package capabilities
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD9
2 files changed, 14 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19fdf7ce3e3a..b933037d0706 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,8 +9,13 @@ pkgbase = python-pyscaffold
makedepends = python-wheel
depends = python
depends = python-setuptools-scm
- optdepends = python-django: scaffold django projects
- optdepends = python-cookiecutter: create custom scaffold templates
+ optdepends = python-django: Scaffold Django projects.
+ optdepends = python-cookiecutter: Create custom scaffold templates.
+ optdepends = python-pre-commit: Use Git pre-commit hooks.
+ optdepends = python-sphinx: Support building documentation with Sphinx.
+ optdepends = python-pytest: Use the integrated unit testing.
+ optdepends = python-pytest-runner: Use the integrated unit testing.
+ optdepends = python-pytest-cov: Generate a coverage report for your project.
source = pyscaffold-3.1::git+https://github.com/blue-yonder/pyscaffold.git#tag=v3.1
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4a9e38e3c90e..69d6ed36c6aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,13 @@ url="https://pyscaffold.org/"
arch=('any')
license=('MIT')
depends=('python' 'python-setuptools-scm')
-optdepends=('python-django: scaffold django projects'
- 'python-cookiecutter: create custom scaffold templates')
+optdepends=('python-django: Scaffold Django projects.'
+ 'python-cookiecutter: Create custom scaffold templates.'
+ 'python-pre-commit: Use Git pre-commit hooks.'
+ 'python-sphinx: Support building documentation with Sphinx.'
+ 'python-pytest: Use the integrated unit testing.'
+ 'python-pytest-runner: Use the integrated unit testing.'
+ 'python-pytest-cov: Generate a coverage report for your project.')
# makedepends=('python-setuptools-scm' 'python-pbr' 'python-wheel')
makedepends=('git' 'python-wheel')
source=("pyscaffold-${pkgver}::git+https://github.com/blue-yonder/pyscaffold.git#tag=v${pkgver}")