summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Stahlberg2021-02-06 15:17:33 +0100
committerMaximilian Stahlberg2021-02-06 15:17:33 +0100
commit0a3a579a2f9afcc628eb65b5584a9914d019ac63 (patch)
tree7ed8506aa03b781af05d540f59110aa8e8b0e79b
parent3d7740f0cd823666218a3261c1a491ac28a3646d (diff)
downloadaur-0a3a579a2f9afcc628eb65b5584a9914d019ac63.tar.gz
Use awk instead of sed for extracting the Python version.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a780da8f57a..ff532515c020 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyscipopt
pkgdesc = A Python interface to the SCIP Optimization Suite.
pkgver = 3.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://www.scipopt.org/
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 27b1274134e7..77c246e86a78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-pyscipopt
pkgver=3.1.0
-pkgrel=2
+pkgrel=3
pkgdesc='A Python interface to the SCIP Optimization Suite.'
arch=('any')
url='https://www.scipopt.org/'
@@ -20,7 +20,7 @@ build() {
check() {
_arch="linux-$(uname -m)"
- _pymajver="$(python -V | sed 's/Python \([0-9]\+\.[0-9]\+\)\.[0-9]\+/\1/')"
+ _pymajver="$(python -V | awk '{print $2}' | awk -F. '{print $1"."$2}')"
cd "${srcdir}/PySCIPOpt-${pkgver}/build/lib.${_arch}-${_pymajver}"
python -Bc "import pyscipopt"