summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaximilian Stahlberg2018-03-16 17:48:41 +0100
committerMaximilian Stahlberg2018-03-16 17:48:41 +0100
commit1561264086de0f135d3e438d9f02e2ce677f9bc5 (patch)
tree5a28370fd636d65f9f98fa845ebb6bc967169005
downloadaur-1561264086de0f135d3e438d9f02e2ce677f9bc5.tar.gz
Initial package.
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD39
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..13920ad8494f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Fri Mar 16 16:48:09 UTC 2018
+pkgbase = python-pyscipopt-git
+ pkgdesc = A Python Interface to the SCIP Optimization Suite.
+ pkgver = v1.4.0.r12.ge2eb344
+ pkgrel = 1
+ url = http://scip.zib.de
+ arch = any
+ license = MIT
+ makedepends = cython
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ depends = scipoptsuite
+ conflicts = python-pyscipopt
+ conflicts = python2-pyscipopt
+ source = python-pyscipopt-git::git+https://github.com/SCIP-Interfaces/PySCIPOpt.git
+ md5sums = SKIP
+
+pkgname = python-pyscipopt-git
+ depends = scipoptsuite
+ depends = python
+
+pkgname = python2-pyscipopt-git
+ depends = scipoptsuite
+ depends = python2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dff10aeee125
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+pkg
+src
+*.tar.gz
+*.pkg.tar.xz
+python-pyscipopt-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a48cfb232a37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Maximilian Stahlberg <maximilian.stahlberg tu-berlin de>
+
+pkgbase=('python-pyscipopt-git')
+pkgname=('python-pyscipopt-git' 'python2-pyscipopt-git')
+pkgver=v1.4.0.r12.ge2eb344
+pkgrel=1
+pkgdesc='A Python Interface to the SCIP Optimization Suite.'
+arch=('any')
+url='http://scip.zib.de'
+license=('MIT')
+depends=('scipoptsuite')
+conflicts=('python-pyscipopt' 'python2-pyscipopt')
+#provides=('python-pyscipopt' 'python2-pyscipopt') # Not working with conflicts.
+makedepends=('cython' 'python-setuptools' 'python2-setuptools')
+source=("${pkgbase}::git+https://github.com/SCIP-Interfaces/PySCIPOpt.git")
+
+pkgver() {
+ cd "${srcdir}/${pkgbase}"
+
+ git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package_python-pyscipopt-git() {
+ depends+=('python')
+
+ cd "${srcdir}/${pkgbase}"
+
+ python setup.py install --root=${pkgdir} --optimize=1
+}
+
+package_python2-pyscipopt-git() {
+ depends+=('python2')
+
+ cd "${srcdir}/${pkgbase}"
+
+ python2 setup.py install --root=${pkgdir} --optimize=1
+}
+
+md5sums=('SKIP')