summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJerome Leclanche2015-06-09 23:25:36 +0200
committerJerome Leclanche2015-06-09 23:25:36 +0200
commit7470e037634ed025cf8253978f6214f0f4c7fef4 (patch)
tree8d1029469bbf55dedeec6dfa32aacada9b8d60df
downloadaur-7470e037634ed025cf8253978f6214f0f4c7fef4.tar.gz
Initial import from old AUR
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bcdf917243a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-pyscss
+ pkgdesc = A SCSS compiler for Python
+ pkgver = 1.3.2
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/pyScss
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ source = https://pypi.python.org/packages/source/p/pyScss/pyScss-1.3.2.tar.gz
+ sha256sums = 196289e4e6e44505a097e1e7270e9c1bb918717256d5f4cf104f906ec789dfc7
+
+pkgname = python-pyscss
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..499929e47478
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jerome Leclanche <jerome@leclan.ch>
+
+_pkgname=pyScss
+pkgname=python-${_pkgname,,}
+pkgver=1.3.2
+pkgrel=1
+pkgdesc="A SCSS compiler for Python"
+arch=("any")
+license=("GPL")
+url="https://pypi.python.org/pypi/pyScss"
+depends=("python")
+makedepends=("python-setuptools")
+source=("https://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=("196289e4e6e44505a097e1e7270e9c1bb918717256d5f4cf104f906ec789dfc7")
+
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+}