summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRenato Lui Geh2020-04-26 14:53:51 -0300
committerRenato Lui Geh2020-04-26 14:53:51 -0300
commit96018182fa33fe4496b95d96e80e3e47f43a13f2 (patch)
treea472edb16604f0d2f53ab278e6d026500611d8ac
parent6afc3b743f5f8c45d989dbe64a513747358960a3 (diff)
downloadaur-96018182fa33fe4496b95d96e80e3e47f43a13f2.tar.gz
Fix random vtree generation
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD23
3 files changed, 19 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f5bfc877fae..9a58eb7f008b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,8 +11,8 @@ pkgbase = python-pysdd
optdepends = python-numpy
provides = python-pysdd
conflicts = python-pysdd-git
- source = https://files.pythonhosted.org/packages/9a/5d/0bc570dda1dec89de5c1b7954aede5e0690fd9baee282ce20a27cf69f700/PySDD-0.2.10.tar.gz
- sha256sums = ddeaca8a140e6c87c2f4f6d8b7e3260b5089e12fe7565d714523f66d233bb1d8
+ source = git+https://github.com/RenatoGeh/PySDD
+ sha256sums = SKIP
pkgname = python-pysdd
diff --git a/.gitignore b/.gitignore
index 73c466425a55..550cd1e0d714 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
+fork
*.tar.gz
*.tar.xz
clean.sh
diff --git a/PKGBUILD b/PKGBUILD
index eb982fd62efa..2355b382b07c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Renato Lui Geh <renatogeh at gmail dot com>
pkgname=python-pysdd
-_pypiname="PySDD"
+_gitname="PySDD"
pkgver=0.2.10
pkgrel=1
pkgdesc="Python package for Sentential Decision Diagrams (SDD)."
@@ -12,16 +12,25 @@ depends=('python' 'cython')
optdepends=('python-cysignals' 'python-numpy')
provides=("${pkgname}")
conflicts=("${pkgname}-git")
-source=("https://files.pythonhosted.org/packages/9a/5d/0bc570dda1dec89de5c1b7954aede5e0690fd9baee282ce20a27cf69f700/${_pypiname}-${pkgver}.tar.gz")
-sha256sums=('ddeaca8a140e6c87c2f4f6d8b7e3260b5089e12fe7565d714523f66d233bb1d8')
+#source=("https://files.pythonhosted.org/packages/9a/5d/0bc570dda1dec89de5c1b7954aede5e0690fd9baee282ce20a27cf69f700/${_pypiname}-${pkgver}.tar.gz")
+#sha256sums=('ddeaca8a140e6c87c2f4f6d8b7e3260b5089e12fe7565d714523f66d233bb1d8')
+source=("git+https://github.com/RenatoGeh/PySDD")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${_gitname}"
+ git checkout rand
+ git pull
+}
build() {
- cd "$srcdir/${_pypiname}-${pkgver}"
+ #cd "$srcdir/${_pypiname}-${pkgver}"
+ cd "${_gitname}"
python3 setup.py build
}
package() {
- cd "$srcdir/${_pypiname}-${pkgver}"
- python3 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ #cd "$srcdir/${_pypiname}-${pkgver}"
+ cd "${_gitname}"
+ python3 setup.py install --root="$pkgdir" --optimize=2 --skip-build
}
-