summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpyros Stathopoulos2015-06-13 14:06:43 +0300
committerSpyros Stathopoulos2015-06-13 14:06:43 +0300
commit6235425cac60831fedb70e52fd893c9676110c99 (patch)
treedb5872524916dc93c18bf6bcbdea22b55fc7e5bb
downloadaur-python-pysmell.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD41
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..58498f3edef2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-pysmell
+ pkgdesc = An autocompletion library for Python
+ pkgver = 0.7.3
+ pkgrel = 4
+ url = http://pypi.python.org/pypi/pysmell
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = setuptools
+ depends = python2
+ optdepends = pymacs: for emacs integration
+ optdepends = vim: for vim integration
+ source = http://pypi.python.org/packages/source/p/pysmell/pysmell-0.7.3.zip
+ md5sums = 4161fa810a8e7147a35a94abfb28d9cd
+
+pkgname = python-pysmell
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..995bbc514134
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+pkg/*
+src/*
+*.tar.gz
+*.tar.xz
+*.tar.bz2
+*.zip
+*.swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56c4488a3f98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id: pkgbuild-mode.el,v 1.23 2007/10/20 16:02:14 juergen Exp $
+# Maintainer: Spyros Stathopoulos <foucault.online@gmail.com>
+pkgname=python-pysmell
+pkgver=0.7.3
+pkgrel=4
+pkgdesc="An autocompletion library for Python"
+url="http://pypi.python.org/pypi/pysmell"
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('python2')
+makedepends=('setuptools')
+optdepends=(
+ 'pymacs: for emacs integration'
+ 'vim: for vim integration'
+ )
+source=(http://pypi.python.org/packages/source/p/pysmell/pysmell-${pkgver}.zip)
+md5sums=('4161fa810a8e7147a35a94abfb28d9cd')
+
+build() {
+ cd ${srcdir}/pysmell-$pkgver
+ sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
+ -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
+ $(find ./ -name '*.py')
+
+ python2 setup.py build
+
+}
+
+package() {
+ cd ${srcdir}/pysmell-$pkgver
+ python2 setup.py install --prefix=/usr --root=${pkgdir}
+
+ # create directories for the pysmell support files
+ install -d $pkgdir/usr/share/emacs/site-lisp
+ install -d $pkgdir/usr/share/vim/plugin
+
+ install -m644 $startdir/src/pysmell-$pkgver/pysmell.el -t $pkgdir/usr/share/emacs/site-lisp
+ install -m644 $startdir/src/pysmell-$pkgver/pysmell.vim -t $pkgdir/usr/share/vim/plugin
+}
+
+# vim:ts=2:sw=2:et