summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRich Li2015-06-08 14:32:17 -0600
committerRich Li2015-06-08 14:32:17 -0600
commit45a86ff3bc152c2e532ebd409765cd1b2b178702 (patch)
tree6dc03a2d2718e49e493bd28274db5cef5a20cab9
downloadaur-45a86ff3bc152c2e532ebd409765cd1b2b178702.tar.gz
Import version 2.0.11 from old AUR
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebcf005a47a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-pyspf
+ pkgdesc = Python implementation of the Sender Policy Framework (SPF) protocol
+ pkgver = 2.0.11
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/pyspf
+ arch = i686
+ arch = x86_64
+ license = PSF
+ makedepends = python-setuptools
+ depends = python-pydns
+ optdepends = python-authres: Return RFC 5451 Authentication Results headers
+ source = http://pypi.python.org/packages/source/p/pyspf/pyspf-2.0.11.tar.gz
+ md5sums = 83add3a0d8732bcc28841ceb5da440ba
+
+pkgname = python-pyspf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a63b0efdb894
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Rich Li <rich at dranek com>
+# Contributor: Samed Beyribey <ras0ir AT eventualis DOT org>
+pkgname=python-pyspf
+pkgver=2.0.11
+pkgrel=1
+pkgdesc="Python implementation of the Sender Policy Framework (SPF) protocol"
+arch=('i686' 'x86_64')
+url="http://pypi.python.org/pypi/pyspf"
+license=('PSF')
+depends=('python-pydns')
+makedepends=('python-setuptools')
+optdepends=('python-authres: Return RFC 5451 Authentication Results headers')
+source=(http://pypi.python.org/packages/source/p/pyspf/pyspf-$pkgver.tar.gz)
+md5sums=('83add3a0d8732bcc28841ceb5da440ba')
+
+build() {
+ cd "$srcdir/pyspf-$pkgver"
+ python setup.py build
+}
+
+# The package requires installation before testing...so it won't work here
+# check() {
+# }
+
+package() {
+ cd "$srcdir/pyspf-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}
+# vim:set ts=2 sw=2 et: