summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault2019-02-27 21:58:47 -0500
committerDrew DeVault2019-02-27 21:58:47 -0500
commit0874c68e66eecefe5cb7ea54276c7f2aa29c55ad (patch)
tree6300c3edea683da880e98b47936c4000fbf9a94e
parente0f870e9f26abce12fed5f8bf3260283ad2807ae (diff)
downloadaur-0874c68e66eecefe5cb7ea54276c7f2aa29c55ad.tar.gz
Fix test suite, upstream URL, install LICENSE
-rw-r--r--PKGBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 772dc1f8b7bf..169782e9b0e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ arch=("any")
url="http://github.com/defunkt/pystache"
license=('MIT')
depends=('python-setuptools')
-source=("$pkgname-$pkgver.tar.gz::https://pypi.python.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/defunkt/$_pkgname/archive/v$pkgver.tar.gz")
sha256sums=('f7bbc265fb957b4d6c7c042b336563179444ab313fb93a719759111eabd3b85a')
build() {
@@ -16,7 +16,19 @@ build() {
python setup.py build
}
+check() {
+ # This package uses 2to3 to convert itself to Python 3 on the fly
+ # So we need to jump through some hoops here
+ rm -rf test_dir
+ mkdir test_dir
+ cd "$_pkgname-$pkgver"
+ python setup.py install --root=../test_dir
+ PYTHONPATH=../test_dir/usr/lib/python3.7/site-packages/ \
+ ../test_dir/usr/bin/pystache-test .
+}
+
package() {
cd "$_pkgname-$pkgver"
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
}