summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Klink2015-07-24 13:14:51 +0200
committerFlorian Klink2015-07-24 13:14:51 +0200
commit650320db7e8adedbd72619bdd5a86399ef1bf9e5 (patch)
tree7fbb824d941d22fbb9b8d57fa9b8847bc9883bc6
downloadaur-650320db7e8adedbd72619bdd5a86399ef1bf9e5.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e235bf2ecac4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-pystache
+ pkgdesc = The mustache template engine written in python
+ pkgver = 0.5.4
+ pkgrel = 1
+ url = http://github.com/defunkt/pystache
+ arch = any
+ license = MIT
+ depends = python
+ provides = python-pystache
+ conflicts = python-pystache
+ source = https://pypi.python.org/packages/source/p/pystache/pystache-0.5.4.tar.gz
+ md5sums = 485885e67a0f6411d5252e69b20a35ca
+
+pkgname = python-pystache
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f97bd8cf222
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Florian Klink <flokli at flokli dot de>
+
+_python=python
+_distname=pystache
+pkgname=$_python-$_distname
+pkgver=0.5.4
+pkgrel=1
+pkgdesc="The mustache template engine written in python"
+arch=(any)
+url="http://github.com/defunkt/pystache"
+license=('MIT')
+depends=('python')
+makedepends=('')
+provides=('python-pystache')
+conflicts=('python-pystache')
+source=( "https://pypi.python.org/packages/source/${_distname:0:1}/$_distname/$_distname-$pkgver.tar.gz")
+md5sums=('485885e67a0f6411d5252e69b20a35ca')
+
+package() {
+ cd "$srcdir/$_distname-$pkgver"
+ $_python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 || exit 1
+}