summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2019-12-06 21:30:34 +0100
committeractionless2019-12-06 21:30:34 +0100
commitd8547cd6869c3f06ac3d33be5f0a740f7b6c868b (patch)
treebf5a3bb1fbbec88c4b4930e872b4bc865b2319c1
parent7b6084660d83a2146e2239803455291a5ee5eef1 (diff)
downloadaur-d8547cd6869c3f06ac3d33be5f0a740f7b6c868b.tar.gz
define test dir path in variable
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dff1af17593..31a520979d89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,14 +18,15 @@ build() {
}
check() {
+ cd "$_pkgname-$pkgver"
# This package uses 2to3 to convert itself to Python 3 on the fly
# So we need to jump through some hoops here
- rm -rf test_dir
- mkdir test_dir
- cd "$_pkgname-$pkgver"
- python setup.py install --root=../test_dir
- PYTHONPATH=../test_dir/usr/lib/python*/site-packages/ \
- ../test_dir/usr/bin/pystache-test .
+ test_dir="../test_dir"
+ rm -rf "$test_dir"
+ mkdir "$test_dir"
+ python setup.py install --root="$test_dir"
+ PYTHONPATH="$test_dir"/usr/lib/python*/site-packages/ \
+ "$test_dir"/usr/bin/pystache-test .
}
package() {