summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Gabriel Young2019-06-23 16:35:57 -0400
committerJean-Gabriel Young2019-06-23 16:35:57 -0400
commit10daff16516e29fb70a21e07447b4a4157f621cf (patch)
tree3e6363726b934b73d29c5cd026f0a0548cfe095c
parent03216200dfc0d122aeccb19610b5f7da546cf6ee (diff)
downloadaur-10daff16516e29fb70a21e07447b4a4157f621cf.tar.gz
Modified PKGBUILD to use installed C++ libraries instead of libraries shipped with pystan
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
-rw-r--r--use-usr-libs.patch18
3 files changed, 32 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62108ce58336..c1bb52f903e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,20 @@
pkgbase = python-pystan
pkgdesc = Python interface to Stan, a package for Bayesian inference.
pkgver = 2.19.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://mc-stan.org/
arch = i686
arch = x86_64
license = GPLv3
depends = python-numpy
depends = cython
+ depends = boost
+ depends = eigen
+ depends = sundials
source = https://files.pythonhosted.org/packages/source/p/pystan/pystan-2.19.0.0.tar.gz
+ source = use-usr-libs.patch
sha256sums = b85301b960d5991918b40bd64a4e9321813657a9fc028e0f39edce7220a309eb
+ sha256sums = 4446891828e63f3541f3386cd5b44f35d575646dcc328016d23524756e35252a
pkgname = python-pystan
diff --git a/PKGBUILD b/PKGBUILD
index 1022b8e5aca1..a12762749410 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,19 @@
pkgname=python-pystan
pkgver=2.19.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python interface to Stan, a package for Bayesian inference."
arch=('i686' 'x86_64')
url='http://mc-stan.org/'
license=(GPLv3)
-depends=(python-numpy cython)
+depends=(python-numpy cython boost eigen sundials)
_name=${pkgname#python-}
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('b85301b960d5991918b40bd64a4e9321813657a9fc028e0f39edce7220a309eb')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz" "use-usr-libs.patch")
+sha256sums=('b85301b960d5991918b40bd64a4e9321813657a9fc028e0f39edce7220a309eb'
+ '4446891828e63f3541f3386cd5b44f35d575646dcc328016d23524756e35252a')
+prepare() {
+ patch --strip=0 --input=use-usr-libs.patch
+}
build() {
cd ${_name}-${pkgver}
python setup.py build
diff --git a/use-usr-libs.patch b/use-usr-libs.patch
new file mode 100644
index 000000000000..fe920f187234
--- /dev/null
+++ b/use-usr-libs.patch
@@ -0,0 +1,18 @@
+diff --unified --recursive --text pystan-2.19.0.0/setup.py pystan-2.19.0.0/setup.py
+--- pystan-2.19.0.0/setup.py 2019-04-02 16:12:04.000000000 -0400
++++ pystan-2.19.0.0/setup.py 2019-06-23 15:55:25.641273923 -0400
+@@ -100,9 +100,11 @@
+
+ stan_include_dirs = ['pystan/stan/src',
+ 'pystan/stan/lib/stan_math/',
+- 'pystan/stan/lib/stan_math/lib/eigen_3.3.3',
+- 'pystan/stan/lib/stan_math/lib/boost_1.69.0',
+- 'pystan/stan/lib/stan_math/lib/sundials_4.1.0/include']
++ '/usr/include/eigen3/',
++ '/usr/include/boost/',
++ '/usr/include/sundials/',
++ '/usr/include/cvode/',
++ '/usr/include/cvodes/']
+ stan_macros = [
+ ('BOOST_DISABLE_ASSERTS', None),
+ ('BOOST_NO_DECLTYPE', None),