summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean-Gabriel Young2020-03-20 15:10:58 -0400
committerJean-Gabriel Young2020-03-20 15:10:58 -0400
commitd2d23b0a1e5e879533c92ae7e1cb159c9f6ae910 (patch)
treeb69cbf5d23b2559934736e10304a44fb83d48c59
parent10daff16516e29fb70a21e07447b4a4157f621cf (diff)
downloadaur-d2d23b0a1e5e879533c92ae7e1cb159c9f6ae910.tar.gz
2.19.1.1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
-rw-r--r--use-usr-libs.patch18
3 files changed, 9 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1bb52f903e6..3247538159a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,15 @@
pkgbase = python-pystan
pkgdesc = Python interface to Stan, a package for Bayesian inference.
- pkgver = 2.19.0.0
+ pkgver = 2.19.1.1
pkgrel = 2
url = http://mc-stan.org/
arch = i686
arch = x86_64
- license = GPLv3
+ license = GPL3
depends = python-numpy
depends = cython
- depends = boost
- depends = eigen
- depends = sundials
- source = https://files.pythonhosted.org/packages/source/p/pystan/pystan-2.19.0.0.tar.gz
- source = use-usr-libs.patch
- sha256sums = b85301b960d5991918b40bd64a4e9321813657a9fc028e0f39edce7220a309eb
- sha256sums = 4446891828e63f3541f3386cd5b44f35d575646dcc328016d23524756e35252a
+ source = https://files.pythonhosted.org/packages/source/p/pystan/pystan-2.19.1.1.tar.gz
+ sha256sums = fa8bad8dbc0da22bbe6f36af56c9abbfcf10f92df8ce627d59a36bd8d25eb038
pkgname = python-pystan
diff --git a/PKGBUILD b/PKGBUILD
index a12762749410..cc947efe37dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,16 @@
# Maintainer: Jean-Gabriel Young <info@jgyoung.ca>
pkgname=python-pystan
-pkgver=2.19.0.0
+pkgver=2.19.1.1
pkgrel=2
pkgdesc="Python interface to Stan, a package for Bayesian inference."
arch=('i686' 'x86_64')
url='http://mc-stan.org/'
-license=(GPLv3)
-depends=(python-numpy cython boost eigen sundials)
+license=(GPL3)
+depends=(python-numpy cython)
_name=${pkgname#python-}
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz" "use-usr-libs.patch")
-sha256sums=('b85301b960d5991918b40bd64a4e9321813657a9fc028e0f39edce7220a309eb'
- '4446891828e63f3541f3386cd5b44f35d575646dcc328016d23524756e35252a')
-prepare() {
- patch --strip=0 --input=use-usr-libs.patch
-}
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('fa8bad8dbc0da22bbe6f36af56c9abbfcf10f92df8ce627d59a36bd8d25eb038')
build() {
cd ${_name}-${pkgver}
python setup.py build
diff --git a/use-usr-libs.patch b/use-usr-libs.patch
deleted file mode 100644
index fe920f187234..000000000000
--- a/use-usr-libs.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --unified --recursive --text pystan-2.19.0.0/setup.py pystan-2.19.0.0/setup.py
---- pystan-2.19.0.0/setup.py 2019-04-02 16:12:04.000000000 -0400
-+++ pystan-2.19.0.0/setup.py 2019-06-23 15:55:25.641273923 -0400
-@@ -100,9 +100,11 @@
-
- stan_include_dirs = ['pystan/stan/src',
- 'pystan/stan/lib/stan_math/',
-- 'pystan/stan/lib/stan_math/lib/eigen_3.3.3',
-- 'pystan/stan/lib/stan_math/lib/boost_1.69.0',
-- 'pystan/stan/lib/stan_math/lib/sundials_4.1.0/include']
-+ '/usr/include/eigen3/',
-+ '/usr/include/boost/',
-+ '/usr/include/sundials/',
-+ '/usr/include/cvode/',
-+ '/usr/include/cvodes/']
- stan_macros = [
- ('BOOST_DISABLE_ASSERTS', None),
- ('BOOST_NO_DECLTYPE', None),