summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Laker2020-02-22 19:14:35 -0500
committerKyle Laker2020-02-22 19:14:35 -0500
commit2d1679750da9df23b51734e672290ddc311ed8f3 (patch)
treebcc6878b2e24cb7bc251953a9064212b1722f6c9
downloadaur-2d1679750da9df23b51734e672290ddc311ed8f3.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d02a7879681b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-pystemd
+ pkgdesc = A thin Cython-based wrapper on top of libsystemd, focused on exposing the dbus API via sd-bus in an automated and easy to consume way.
+ pkgver = 0.7
+ pkgrel = 1
+ url = https://github.com/facebookincubator/pystemd
+ arch = any
+ license = LGPL2.1
+ makedepends = python-setuptools
+ depends = python
+ depends = python-setuptools
+ depends = cython
+ depends = python-mock
+ depends = python-pypandoc
+ source = python-pystemd-0.7.tar.gz::https://github.com/facebookincubator/pystemd/archive/v0.7.tar.gz
+ md5sums = a287210503fe1c08cef612d09f76f790
+
+pkgname = python-pystemd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..917863e0075f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Kyle Laker <kyle+aur at laker dot email>
+pkgname='python-pystemd'
+_name="${pkgname#python-}"
+pkgver='0.7'
+pkgrel=1
+pkgdesc='A thin Cython-based wrapper on top of libsystemd, focused on exposing the dbus API via sd-bus in an automated and easy to consume way.'
+arch=('any')
+url='https://github.com/facebookincubator/pystemd'
+license=('LGPL2.1')
+depends=('python' 'python-setuptools' 'cython' 'python-mock' 'python-pypandoc')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
+md5sums=('a287210503fe1c08cef612d09f76f790')
+
+build() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}