summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Laker2022-05-01 00:22:12 -0400
committerKyle Laker2022-05-01 00:26:48 -0400
commitaaccef0e41eea92a701d75c738f78d63307d7833 (patch)
tree7266ed9ef80aaa2c011ec395f0e4e24b3735a852
parent003d6b0051baaa37226c009988a7b8567ab52057 (diff)
downloadaur-aaccef0e41eea92a701d75c738f78d63307d7833.tar.gz
Update to 0.10.0
This updates the package to 0.10.0 and fixes other general packaging issues identified by post-factum. `cython` is a dev dependency and `systemd` is a runtime dependency. `arch` is set to `x86_64` since the compiled output is architecture specific but I have not validated that the compilation succeeded on non-AMD64 architectures.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 882bc3c33732..448227b557ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = python-pystemd
pkgdesc = A thin Cython-based wrapper on top of libsystemd, focused on exposing the dbus API via sd-bus in an automated and easy to consume way.
- pkgver = 0.9.0
+ pkgver = 0.10.0
pkgrel = 1
url = https://github.com/facebookincubator/pystemd
- arch = any
+ arch = x86_64
license = LGPL2.1
makedepends = python-setuptools
+ makedepends = cython
depends = python
- depends = cython
- source = python-pystemd-0.9.0.tar.gz::https://github.com/facebookincubator/pystemd/archive/v.0.9.0.tar.gz
- md5sums = f9be8301d4be4dff2c9f112879b71b9f
+ depends = systemd
+ source = python-pystemd-0.10.0.tar.gz::https://github.com/facebookincubator/pystemd/archive/v.0.10.0.tar.gz
+ md5sums = 38fa18faa457fb15e680667895e7b952
pkgname = python-pystemd
diff --git a/PKGBUILD b/PKGBUILD
index 3b2a7360dd07..c9520366839f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer: Kyle Laker <kyle+aur at laker dot email>
pkgname='python-pystemd'
_name="${pkgname#python-}"
-pkgver='0.9.0'
+pkgver='0.10.0'
pkgrel=1
pkgdesc='A thin Cython-based wrapper on top of libsystemd, focused on exposing the dbus API via sd-bus in an automated and easy to consume way.'
-arch=('any')
+arch=('x86_64')
url='https://github.com/facebookincubator/pystemd'
license=('LGPL2.1')
-depends=('python' 'cython')
-makedepends=('python-setuptools')
+depends=('python' 'systemd')
+makedepends=('python-setuptools' 'cython')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v.${pkgver}.tar.gz")
-md5sums=('f9be8301d4be4dff2c9f112879b71b9f')
+md5sums=('38fa18faa457fb15e680667895e7b952')
build() {
cd "${srcdir}/${_name}-v.${pkgver}"