summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Harting2024-03-23 20:00:49 +0100
committerGiovanni Harting2024-03-23 20:00:49 +0100
commit159e9dbcc0bdfe1c01251837a4e28623d215ca06 (patch)
tree5034b181e537843d55a2a0feb0843a8353a7d5ce
parent2a6f7e624f3f35c8f830a538a263af104c12ebf0 (diff)
downloadaur-python-pystray.tar.gz
upgpkg: python-pystray 0.19.5-3
add missing deps
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
2 files changed, 16 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc6f34f55bac..74d9c3de1e7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-pystray
pkgdesc = Allows to create a system tray icon
pkgver = 0.19.5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/moses-palmer/pystray
arch = any
- license = GPL3
+ license = GPL-3.0-only
+ license = LGPL-3.0-only
makedepends = python-build
makedepends = python-installer
makedepends = python-wheel
@@ -15,6 +16,9 @@ pkgbase = python-pystray
depends = python-xlib>=0.17
depends = libappindicator-gtk3
depends = python-gobject
+ depends = gtk3
+ depends = python
+ depends = gobject-introspection-runtime
source = python-pystray-0.19.5.tar.gz::https://github.com/moses-palmer/pystray/archive/v0.19.5.tar.gz
b2sums = 34bea3d14cfde7ee7a7d2594da2386265fba34b36f4699b5877ea393dbf7e844fe441a1bda384bb6b3f279a544cba897e04509f7c47d69cb5168793665ae73d4
diff --git a/PKGBUILD b/PKGBUILD
index b92e108e700e..0a5915271933 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,24 @@
pkgname=python-pystray
pkgver=0.19.5
-pkgrel=2
+pkgrel=3
arch=(any)
-license=(GPL3)
-pkgdesc="Allows to create a system tray icon"
-url="https://github.com/moses-palmer/pystray"
-depends=(python-six python-pillow 'python-xlib>=0.17' libappindicator-gtk3 python-gobject)
+license=(GPL-3.0-only LGPL-3.0-only)
+pkgdesc='Allows to create a system tray icon'
+url='https://github.com/moses-palmer/pystray'
+depends=(python-six python-pillow 'python-xlib>=0.17' libappindicator-gtk3 python-gobject gtk3 python gobject-introspection-runtime)
makedepends=(python-build python-installer python-wheel python-setuptools python-sphinx)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/moses-palmer/pystray/archive/v${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
b2sums=('34bea3d14cfde7ee7a7d2594da2386265fba34b36f4699b5877ea393dbf7e844fe441a1bda384bb6b3f279a544cba897e04509f7c47d69cb5168793665ae73d4')
build() {
- cd "pystray-$pkgver"
+ cd pystray-$pkgver
python -m build --wheel --no-isolation
}
package_python-pystray() {
- cd "pystray-$pkgver"
+ cd pystray-$pkgver
python -m installer --destdir="$pkgdir" dist/*.whl
}
+
+# vim:set ts=2 sw=2 et: