summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-08-08 09:40:11 +1200
committercaltlgin2020-08-08 09:40:11 +1200
commit4660fc0039e385d3d1e526f94558be03aba535c4 (patch)
tree7a991a842561c32072489ace7a7ef4c4992045e0
parent4da0849c0d66c4cbde910a3b36763d235d6f6385 (diff)
downloadaur-4660fc0039e385d3d1e526f94558be03aba535c4.tar.gz
Update to v0.55.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 35 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d6d2da281cae..a2d44ebb93a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = python-pytablewriter
pkgdesc = Python library to write a table in various formats
- pkgver = 0.50.0
+ pkgver = 0.55.0
pkgrel = 1
url = https://github.com/thombashi/pytablewriter
arch = any
license = MIT
makedepends = python-setuptools
- depends = python-xlwt
- depends = python-dominate
- depends = python-simplejson
- depends = python-toml
- depends = python-loguru
- depends = python-elasticsearch
- source = https://pypi.io/packages/source/p/pytablewriter/pytablewriter-0.50.0.tar.gz
- sha256sums = aa483f67653b130b50f076763d7a2e84fff3c096c032ffd64b78e735edc21a3d
+ depends = python-dataproperty
+ depends = python-mbstrdecoder
+ depends = python-msgfy
+ depends = python-pathvalidate
+ depends = python-tabledata
+ depends = python-tcolorpy
+ depends = python-typepy
+ provides = pytablewriter
+ source = https://files.pythonhosted.org/packages/source/p/pytablewriter/pytablewriter-0.55.0.tar.gz
+ sha256sums = 61073974ce5fe1cbd5d9f529e18df44b01ba135da4b379a52865ce7eb5af97c6
pkgname = python-pytablewriter
diff --git a/PKGBUILD b/PKGBUILD
index 7687297f22aa..c67f83e70a0a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,30 @@
-pkgname=python-pytablewriter
-pkgver=0.50.0
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: xantares
+
+_pkgname=pytablewriter
+pkgname=python-${_pkgname}
+pkgver=0.55.0
pkgrel=1
-pkgdesc="Python library to write a table in various formats"
-arch=(any)
-url="https://github.com/thombashi/pytablewriter"
+pkgdesc='Python library to write a table in various formats'
+arch=('any')
+url='https://github.com/thombashi/pytablewriter'
license=('MIT')
+depends=('python-dataproperty' 'python-mbstrdecoder' 'python-msgfy' 'python-pathvalidate' 'python-tabledata' 'python-tcolorpy' 'python-typepy')
makedepends=('python-setuptools')
-depends=('python-xlwt' 'python-dominate' 'python-simplejson' 'python-toml' 'python-loguru' 'python-elasticsearch')
-source=("https://pypi.io/packages/source/p/pytablewriter/pytablewriter-$pkgver.tar.gz")
-sha256sums=('aa483f67653b130b50f076763d7a2e84fff3c096c032ffd64b78e735edc21a3d')
+provides=("${_pkgname}")
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('61073974ce5fe1cbd5d9f529e18df44b01ba135da4b379a52865ce7eb5af97c6')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
package() {
- cd pytablewriter-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${_pkgname}" 'README.rst'
+ install -Dm644 -t "${pkgdir}/usr/share/licenses/${_pkgname}" 'LICENSE'
}
+
+# vim: ts=2 sw=2 et: