summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán2024-03-19 21:19:46 -0500
committerCarlos Aznarán2024-03-19 21:19:46 -0500
commit34995c42f80355a059a40080cba31c3d0dae7525 (patch)
tree82262850609dfb93f22dc1a265c2d0e2d3145cc1
parentf3a5d496ed31072940662cded87677e67be1cf45 (diff)
downloadaur-python-pytaglib.tar.gz
Bump version to 3.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--.nvchecker.toml5
-rw-r--r--PKGBUILD13
3 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 754e9d95c82a..90ce6ebb6441 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-pytaglib
pkgdesc = Python audio tagging library
- pkgver = 2.1.0
+ pkgver = 3.0.0
pkgrel = 1
url = https://github.com/supermihi/pytaglib
arch = x86_64
- license = GPL3
+ license = GPL-3.0-or-later
checkdepends = python-pytest
makedepends = python-build
makedepends = python-installer
@@ -13,7 +13,7 @@ pkgbase = python-pytaglib
makedepends = python-wheel
depends = python
depends = taglib
- source = pytaglib-2.1.0.tar.gz::https://github.com/supermihi/pytaglib/archive/v2.1.0.tar.gz
- sha512sums = 50c7fa4e5f56f1a6ce18594239335bf281467f708c56579523e5826a39a647a3654d703f18c745c4703a653cbccb9cc8cbfaf7f3c02ea704d74c3d1616a2cdb9
+ source = pytaglib-3.0.0.tar.gz::https://github.com/supermihi/pytaglib/archive/v3.0.0.tar.gz
+ sha512sums = ade4192fd1cc8331d722ccd30852275577bfd9fc3a638de9e6be8723dbfaa6246704ad8c284d52e2138912903a71641f122b777ff646cb9d0571e7596d601426
pkgname = python-pytaglib
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..f850b3c8f04c
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,5 @@
+[python-pytaglib]
+source = "github"
+github = "supermihi/pytaglib"
+use_latest_release = "true"
+prefix = "v" \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 3a9718e72834..40e5255c4208 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,17 @@
# Contributor: Antonio Rojas <arojas@archlinux.org>
_base=pytaglib
pkgname=python-${_base}
-pkgver=2.1.0
+pkgver=3.0.0
pkgrel=1
pkgdesc="Python audio tagging library"
arch=(x86_64)
url="https://github.com/supermihi/${_base}"
-license=(GPL3)
+license=(GPL-3.0-or-later)
depends=(python taglib)
makedepends=(python-build python-installer python-setuptools cython python-wheel)
checkdepends=(python-pytest)
source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
-sha512sums=('50c7fa4e5f56f1a6ce18594239335bf281467f708c56579523e5826a39a647a3654d703f18c745c4703a653cbccb9cc8cbfaf7f3c02ea704d74c3d1616a2cdb9')
+sha512sums=('ade4192fd1cc8331d722ccd30852275577bfd9fc3a638de9e6be8723dbfaa6246704ad8c284d52e2138912903a71641f122b777ff646cb9d0571e7596d601426')
build() {
cd ${_base}-${pkgver}
@@ -30,10 +30,5 @@ check() {
package() {
cd ${_base}-${pkgver}
PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
-
- # Symlink license file
- local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
- install -d ${pkgdir}/usr/share/licenses/${pkgname}
- ln -s "${site_packages}/${_base}-${pkgver}.dist-info/LICENSE" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}