summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-24 21:18:31 -0500
committerCarlos Aznarán Laos2022-10-24 21:18:31 -0500
commit924c2d28bc05987ec2f06f040fe8b8b9e2895f66 (patch)
treee3662c589d5712950ab650536ed504cd0b527b0d
parentb2057c38890b3b2fded3f5d64a1a36b470ebb736 (diff)
downloadaur-924c2d28bc05987ec2f06f040fe8b8b9e2895f66.tar.gz
Change python-install by python-installer
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 4 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6268f9e76281..ff571317f6f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,7 +12,7 @@ pkgbase = python-pytaglib
makedepends = python-wheel
depends = python
depends = taglib
- source = https://github.com/supermihi/pytaglib/archive/v1.5.0.tar.gz
+ source = pytaglib-1.5.0.tar.gz::https://github.com/supermihi/pytaglib/archive/v1.5.0.tar.gz
sha512sums = 1be63e285980b140312aa780a56edf59467ad05aa49b3679d4140a856d07950842e9563ae7783010084e6d82c89b8776bbac94101326f67d041faa410f756556
pkgname = python-pytaglib
diff --git a/PKGBUILD b/PKGBUILD
index 384a7cff80f7..11f9f4d1b9c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ license=(GPL3)
depends=(python taglib)
makedepends=(python-build python-installer python-setuptools python-wheel)
checkdepends=(python-pytest)
-source=(${url}/archive/v${pkgver}.tar.gz)
+source=(${_base}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz)
sha512sums=('1be63e285980b140312aa780a56edf59467ad05aa49b3679d4140a856d07950842e9563ae7783010084e6d82c89b8776bbac94101326f67d041faa410f756556')
build() {
@@ -23,17 +23,13 @@ build() {
check() {
cd ${_base}-${pkgver}
python -m venv --system-site-packages test-env
- test-env/bin/python -m installer --optimize=1 dist/*.whl
- chmod +x test-env/bin/pyprinttags
+ test-env/bin/python -m installer dist/*.whl
test-env/bin/python -m pytest tests
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --optimize=1 --destdir="${pkgdir}" dist/*.whl
-
- # https://github.com/FFY00/python-install/pull/6
- chmod +x ${pkgdir}/usr/bin/pyprinttags
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
# Symlink license file
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")