summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2022-10-24 21:00:31 -0500
committerCarlos Aznarán Laos2022-10-24 21:00:31 -0500
commitb2057c38890b3b2fded3f5d64a1a36b470ebb736 (patch)
treeb615c5893cf0f4d006cb31aaa388ae2fc3dc069b
parent4499fadb458c64563fcf98434e7dfa4485f493c9 (diff)
downloadaur-b2057c38890b3b2fded3f5d64a1a36b470ebb736.tar.gz
Change python-install by python-installer
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e72992917d7..6268f9e76281 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,7 +7,7 @@ pkgbase = python-pytaglib
license = GPL3
checkdepends = python-pytest
makedepends = python-build
- makedepends = python-install
+ makedepends = python-installer
makedepends = python-setuptools
makedepends = python-wheel
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index d7ef65105ba2..384a7cff80f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ arch=(x86_64)
url="https://github.com/supermihi/${_base}"
license=(GPL3)
depends=(python taglib)
-makedepends=(python-build python-install python-setuptools python-wheel)
+makedepends=(python-build python-installer python-setuptools python-wheel)
checkdepends=(python-pytest)
source=(${url}/archive/v${pkgver}.tar.gz)
sha512sums=('1be63e285980b140312aa780a56edf59467ad05aa49b3679d4140a856d07950842e9563ae7783010084e6d82c89b8776bbac94101326f67d041faa410f756556')
@@ -23,14 +23,14 @@ build() {
check() {
cd ${_base}-${pkgver}
python -m venv --system-site-packages test-env
- test-env/bin/python -m install --optimize=1 dist/*.whl
+ test-env/bin/python -m installer --optimize=1 dist/*.whl
chmod +x test-env/bin/pyprinttags
test-env/bin/python -m pytest tests
}
package() {
cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m install --optimize=1 --destdir="${pkgdir}" dist/*.whl
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --optimize=1 --destdir="${pkgdir}" dist/*.whl
# https://github.com/FFY00/python-install/pull/6
chmod +x ${pkgdir}/usr/bin/pyprinttags