summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Helmling2021-12-15 13:37:36 +0100
committerMichael Helmling2021-12-15 13:37:36 +0100
commitffcbba06f367715a5c6f3177212a9ec655aeafdc (patch)
treeae4f8bf01241cbbb6c013e38fc51cfdb69f20fe1
parent59d2d5b0d60f5f1d27f1aec4902422a75fe7643e (diff)
downloadaur-ffcbba06f367715a5c6f3177212a9ec655aeafdc.tar.gz
force calling Cython before build to fix Python 3.10
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7771e5a4191e..67557c99e195 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,20 @@
_base=pytaglib
pkgname=python-${_base}
pkgver=1.4.6
-pkgrel=5
+pkgrel=6
pkgdesc="Python audio tagging library"
arch=(x86_64)
url="https://github.com/supermihi/${_base}"
license=(GPL3)
depends=(python taglib)
-makedepends=(python-setuptools)
+makedepends=(python-setuptools cython)
checkdepends=(python-pytest)
source=(${url}/archive/v${pkgver}.tar.gz)
sha512sums=('4b438759440790b3c850cf165b553f7e6066bf0064e041cca3e46831046b12a87decd4429772ea0c50e1b27cbbd2c82ba709361bc01aa2e8ec3064458aeae0ff')
build() {
cd "${_base}-${pkgver}"
- python setup.py build
+ PYTAGLIB_CYTHONIZE=1 python setup.py build
}
check() {