summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2023-05-10 15:58:04 +0200
committerCarl Smedstad2023-05-10 15:58:31 +0200
commit373f5f88df4e1f0a2ad5d481e874cc4c174912bd (patch)
tree4cf3228de1034eb9587c47690fe5aaa8e691be7f
parentbc8ad784979d5247fab95b0304727140e9d1ab6e (diff)
downloadaur-373f5f88df4e1f0a2ad5d481e874cc4c174912bd.tar.gz
Publish version 2.11.3-1
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
-rw-r--r--remove-bin-package.patch12
4 files changed, 29 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75284eea9241..d9fb9e64cca5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pytensor
pkgdesc = Fork of Aesara -- Library for defining, optimizing, and efficiently evaluating mathematical expressions involving multi-dimensional arrays
- pkgver = 2.11.2
+ pkgver = 2.11.3
pkgrel = 1
url = https://github.com/pymc-devs/pytensor
arch = x86_64
@@ -20,8 +20,9 @@ pkgbase = python-pytensor
depends = python-typing_extensions
optdepends = python-numba: for graph transpilation compilation
optdepends = python-jax: for graph transpilation compilation
- conflicts = python-aesara
- source = python-pytensor-2.11.2.tar.gz::https://github.com/pymc-devs/pytensor/archive/refs/tags/rel-2.11.2.tar.gz
- sha256sums = 5195a3882bf3ab12446aba54d9182198f7558ee33f695284d0e0008798cfb313
+ source = python-pytensor-2.11.3.tar.gz::https://github.com/pymc-devs/pytensor/archive/refs/tags/rel-2.11.3.tar.gz
+ source = remove-bin-package.patch
+ sha256sums = db02ade138d75cfc7e646a66426c17f2b136ef953bd93f978978519b8d047050
+ sha256sums = 73360d53a5c5e5718a544c69218d3d64adc2390007a9b6781f7b61cc32415e59
pkgname = python-pytensor
diff --git a/.gitignore b/.gitignore
index f71c635dafda..3cc0ef12114c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!remove-bin-package.patch
diff --git a/PKGBUILD b/PKGBUILD
index 1ea82340611b..53d38d3885b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,12 @@
pkgname=python-pytensor
_name=${pkgname#python-}
-pkgver=2.11.2
+pkgver=2.11.3
pkgrel=1
pkgdesc="Fork of Aesara -- Library for defining, optimizing, and efficiently evaluating mathematical expressions involving multi-dimensional arrays"
arch=(x86_64)
url="https://github.com/pymc-devs/pytensor"
license=(custom)
-conflicts=(python-aesara)
makedepends=(
python-build
python-installer
@@ -31,16 +30,22 @@ optdepends=(
'python-jax: for graph transpilation compilation'
)
-source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/rel-${pkgver}.tar.gz")
-sha256sums=('5195a3882bf3ab12446aba54d9182198f7558ee33f695284d0e0008798cfb313')
+source=(
+ "$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/rel-${pkgver}.tar.gz"
+ "remove-bin-package.patch"
+)
+sha256sums=(
+ 'db02ade138d75cfc7e646a66426c17f2b136ef953bd93f978978519b8d047050'
+ '73360d53a5c5e5718a544c69218d3d64adc2390007a9b6781f7b61cc32415e59'
+)
_archive="$_name-rel-$pkgver"
prepare() {
- cd "$_archive"
+ patch --directory="$_archive" --forward --strip=1 --input="$srcdir/remove-bin-package.patch"
+ cd "$_archive"
cp doc/LICENSE.txt LICENSE.txt-copy
- rm -r scripts/ doc/ bin/*.sh
}
build() {
diff --git a/remove-bin-package.patch b/remove-bin-package.patch
new file mode 100644
index 000000000000..18231c90f521
--- /dev/null
+++ b/remove-bin-package.patch
@@ -0,0 +1,12 @@
+diff --unified --recursive --text pytensor-rel-2.11.3.orig/pyproject.toml pytensor-rel-2.11.3/pyproject.toml
+--- pytensor-rel-2.11.3.orig/pyproject.toml 2023-05-10 15:51:29.441470544 +0200
++++ pytensor-rel-2.11.3/pyproject.toml 2023-05-10 15:51:41.784840893 +0200
+@@ -105,7 +105,7 @@
+ ]
+
+ [tool.setuptools.packages.find]
+-include = ["pytensor*", "bin"]
++include = ["pytensor*"]
+
+ [tool.setuptools.package-data]
+ pytensor = [