summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2017-03-12 15:31:25 +0300
committerLev Levitsky2017-03-12 15:31:25 +0300
commit19e53cb7a2f12fdf0127e4ab3d63d8bc66f55c98 (patch)
tree3c3b2ee36d5d31febe54a2e8a453a63addcb18d8
parentd78c875b4b4c5e2053209ede5b2a2e3a0157317e (diff)
downloadaur-19e53cb7a2f12fdf0127e4ab3d63d8bc66f55c98.tar.gz
3.4.1
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG29
-rw-r--r--PKGBUILD4
3 files changed, 33 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca8725665b7c..8f0c494811bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Sep 8 20:02:47 UTC 2016
+# Sun Mar 12 12:29:49 UTC 2017
pkgbase = python-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 3.4
+ pkgver = 3.4.1
pkgrel = 1
url = http://pythonhosted.org/pyteomics
changelog = CHANGELOG
@@ -16,8 +16,8 @@ pkgbase = python-pyteomics
optdepends = python-lxml: for XML parsing modules
optdepends = python-numpy: for most of features, highly recommended
options = !emptydirs
- source = https://pypi.io/packages/source/p/pyteomics/pyteomics-3.4.tar.gz
- md5sums = 3c8d1bcc16c53100e531a10a2853f679
+ source = https://pypi.io/packages/source/p/pyteomics/pyteomics-3.4.1.tar.gz
+ md5sums = 9e1aecc88b7ea6e7bc6e77e6479cbb82
pkgname = python-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 15672ad90dd2..26e06e13a1cc 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,28 @@
+3.4.1
+-----
+
+ - Add selenocysteine ("U") and pyrrolysine ("O") to :py:data:`pyteomics.mass.std_aa_mass` and
+ :py:data:`pyteomics.mass.std_aa_comp`.
+
+ - An optional parameter `encoding` is now accepted by text file readers (:py:func:`pyteomics.mgf.read`
+ and :py:func:`pyteomics.fasta.read`). This can be useful for MGF files with non-ASCII spectrum
+ titles or comments.
+
+ - New function :py:func:`pyteomics.mass.mass.isotopologues`.
+
+ - Performance improvements in :py:func:`pyteomics.electrochem.pI`.
+
+ - Fix the issue in :py:mod:`pyteomics.xml` which resulted in very long processing times for indexed XML files
+ with a byte ordering mark (BOM).
+
+ - Support all standard and non-standard data array names in :py:mod:`pyteomics.mzml`.
+
+ - Change default value of ``retrieve_refs`` in :py:func:`pyteomics.mzid.read` to :py:const:`True`.
+
+ - Preserve unit information extracted from cvParam tags in PSI XML files.
+
+ - Fix in :py:mod:`pyteomics.mzxml`, other minor fixes.
+
3.4
---
@@ -188,8 +213,8 @@ API changes
- All :py:func:`fdr`, :py:func:`qvalues`, and :py:func:`!filter` functions
now accept a new parameter `correction`. It is used for more accurate
- estimation of the number of false positives using TDA (paper with explanation
- submitted to JPR).
+ estimation of the number of false positives using TDA (`paper with explanation
+ <http://dx.doi.org/10.1021/acs.jproteome.6b00144>`_).
- :py:func:`!filter` functions now support both iterator protocol and context
manager protocol. They now also accept the `full_output` parameter, which has
diff --git a/PKGBUILD b/PKGBUILD
index 5c1b9a7c5cfb..a158b7e4543a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
-pkgver=3.4
+pkgver=3.4.1
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -14,7 +14,7 @@ optdepends=('python-matplotlib: for pylab_aux module'
'python-numpy: for most of features, highly recommended')
options=(!emptydirs)
source=("https://pypi.io/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-md5sums=('3c8d1bcc16c53100e531a10a2853f679')
+md5sums=('9e1aecc88b7ea6e7bc6e77e6479cbb82')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"