summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlevitsky2017-07-02 14:54:58 +0300
committerlevitsky2017-07-02 14:54:58 +0300
commit28117c237fc6bff499aad695a09a81cdd6b032d7 (patch)
treef5b900e4902c9773db06181a98ec26bdf0005ad3
parent19e53cb7a2f12fdf0127e4ab3d63d8bc66f55c98 (diff)
downloadaur-28117c237fc6bff499aad695a09a81cdd6b032d7.tar.gz
Version 3.4.2
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG21
-rw-r--r--PKGBUILD6
3 files changed, 27 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f0c494811bd..de72e3e1512b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun Mar 12 12:29:49 UTC 2017
pkgbase = python-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 3.4.1
+ pkgver = 3.4.2
pkgrel = 1
url = http://pythonhosted.org/pyteomics
changelog = CHANGELOG
@@ -16,8 +14,8 @@ pkgbase = python-pyteomics
optdepends = python-lxml: for XML parsing modules
optdepends = python-numpy: for most of features, highly recommended
options = !emptydirs
- source = https://pypi.io/packages/source/p/pyteomics/pyteomics-3.4.1.tar.gz
- md5sums = 9e1aecc88b7ea6e7bc6e77e6479cbb82
+ source = https://pypi.io/packages/source/p/pyteomics/pyteomics-3.4.2.tar.gz
+ md5sums = 36cc4c3bab653fdbe22aec71858a461f
pkgname = python-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 26e06e13a1cc..ae7bcfd51f05 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,24 @@
+3.4.2
+-----
+
+ - New module :py:mod:`pyteomics.ms1` for parsing of MS1 files.
+
+ - :py:class:`mass.Composition` constructor now accepts `ion_type` and `charge` parameters.
+
+ - New functions :py:func:`pyteomics.mzid.DataFrame` and :py:func:`pyteomics.mzid.filter_df`.
+ Their behavior may be refined later on.
+
+ - Changes in behavior of :py:func:`pyteomics.auxiliary.filter` and :py:func:`pyteomics.auxiliary.qvalues`:
+
+ - both functions now always return DataFrames with :py:class:`pandas.DataFrame` input and `full_output=True`.
+
+ - string values of `key`, `is_decoy` and `pep` are substituted with simple itemgetter functions for
+ non-pandas, non-numpy input;
+
+ - additional parameters `score_label`, `decoy_label`, `pep_label`, and `q_label` for output control.
+
+ - Performance optimizations in XML parsing code.
+
3.4.1
-----
diff --git a/PKGBUILD b/PKGBUILD
index a158b7e4543a..226b9635cc53 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
-pkgver=3.4.1
+pkgver=3.4.2
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
-url="http://pythonhosted.org/pyteomics"
+url="http://pyteomics.readthedocs.io"
license=('Apache')
depends=('python' 'python-setuptools')
optdepends=('python-matplotlib: for pylab_aux module'
@@ -14,7 +14,7 @@ optdepends=('python-matplotlib: for pylab_aux module'
'python-numpy: for most of features, highly recommended')
options=(!emptydirs)
source=("https://pypi.io/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-md5sums=('9e1aecc88b7ea6e7bc6e77e6479cbb82')
+md5sums=('36cc4c3bab653fdbe22aec71858a461f')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"