summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2024-02-07 17:22:14 +0100
committerLev Levitsky2024-02-07 17:22:14 +0100
commit561eac6d9a74e945c8d47b91861951524a17fe7d (patch)
treeef02bad1fe0cefa58e02f147ad88692d5d5fd51b
parent826e4d799f6808cf7e6da763f15dacefbacac991 (diff)
downloadaur-561eac6d9a74e945c8d47b91861951524a17fe7d.tar.gz
v4.7
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG23
-rw-r--r--PKGBUILD4
3 files changed, 28 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fda642d0ccd8..f036e4eb673d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.6.3
+ pkgver = 4.7
pkgrel = 1
url = https://pyteomics.readthedocs.io
changelog = CHANGELOG
@@ -18,7 +18,7 @@ pkgbase = python-pyteomics
optdepends = python-dill: needed for multiprocessing when pickle is not enough
optdepends = python-pynumpress: for Numpress support
options = !emptydirs
- source = https://pypi.debian.net/pyteomics/pyteomics-4.6.3.tar.gz
- sha256sums = e3bb11e57da3e52ca768d94fed12c9f66d7300fd58bccbc6736dfc0707fd9546
+ source = https://pypi.debian.net/pyteomics/pyteomics-4.7.tar.gz
+ sha256sums = 9f3f83da617c9e7576a927f1dd668f0725789384545e3bc1fd53401d829534c2
pkgname = python-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index e8e9a2645f39..cedee317ee4d 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,26 @@
+4.7
+---
+
+ - Make :py:class:`proforma.MassModification` objects hashable
+ (`#130 <https://github.com/levitsky/pyteomics/pull/130>`_ by Joshua Klein).
+ - Fix `#132 <https://github.com/levitsky/pyteomics/issues/132>`_
+ (`#133 <https://github.com/levitsky/pyteomics/pull/133>`_ by Joshua Klein).
+ - Fix thermolysin cleavage rule (`#135 <https://github.com/levitsky/pyteomics/issues/135>`_).
+ - Fix `#136 <https://github.com/levitsky/pyteomics/issues/136>`_.
+ - :py:func:`pyteomics.mass.mass.calculate_mass` now supports `ProForma <https://www.psidev.info/proforma>`_.
+ A sequence or a :py:class:`proforma.ProForma` object can be passed with the `proforma` keyword argument
+ (`#137 <https://github.com/levitsky/pyteomics/pull/137>`_).
+ - Fix: restored the ability of :py:class:`IndexedTextReader` parsers (:py:class:`pyteomics.mgf.IndexedMGF`,
+ :py:class:`pyteomics.fasta.IndexedFASTA`, etc.) to load the byte offset index from a previously saved byte offset file
+ (created with :py:meth:`cls.prebuild_byte_offset_file` or :py:meth:`reader.write_byte_offsets`)
+ (`#142 <https://github.com/levitsky/pyteomics/pull/142>`_).
+ - API change: uncodumented method :py:meth:`_build_index` of indexing XML parsers renamed to :py:meth:`build_byte_index`
+ (`#142 <https://github.com/levitsky/pyteomics/pull/142>`_).
+ - Add a warning when creating an :py:class:`IndexedTextReader` instance with an empty offset index.
+ This warning can be disabled by passing `warn_if_empty=False`
+ (`#138 <https://github.com/levitsky/pyteomics/pull/138>`_).
+
+
4.6.3
-----
diff --git a/PKGBUILD b/PKGBUILD
index dc383e4d6aa8..0ff9a6f68f46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
_name=${pkgname#python-}
-pkgver=4.6.3
+pkgver=4.7
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -18,7 +18,7 @@ optdepends=('python-matplotlib: for pylab_aux module'
'python-pynumpress: for Numpress support')
options=(!emptydirs)
source=("https://pypi.debian.net/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('e3bb11e57da3e52ca768d94fed12c9f66d7300fd58bccbc6736dfc0707fd9546')
+sha256sums=('9f3f83da617c9e7576a927f1dd668f0725789384545e3bc1fd53401d829534c2')
changelog=CHANGELOG
build() {