summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2016-09-08 22:57:37 +0300
committerLev Levitsky2016-09-08 22:57:37 +0300
commit662313c3c455f2367ad4fdead1aaf80d3f24aa51 (patch)
treefe900f8d1f74ac73ddfed522c466164e8a003998
parent15b5333d9710c0080574830d4b1d81f1fa4389c9 (diff)
downloadaur-662313c3c455f2367ad4fdead1aaf80d3f24aa51.tar.gz
Version 3.4
-rw-r--r--.SRCINFO13
-rw-r--r--CHANGELOG104
-rw-r--r--PKGBUILD11
3 files changed, 115 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8cdabbd9a225..846d0dc700e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Sep 8 19:56:16 UTC 2016
pkgbase = python-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 3.1.1
+ pkgver = 3.4
pkgrel = 1
url = http://pythonhosted.org/pyteomics
changelog = CHANGELOG
@@ -8,13 +10,14 @@ pkgbase = python-pyteomics
license = Apache
depends = python
depends = python-setuptools
- optdepends = python-matplotlib: for pylab_aux module, optional
+ optdepends = python-matplotlib: for pylab_aux module
+ optdepends = python-sqlalchemy: for mass.unimod module
optdepends = python-pandas: for convenient filtering of CSV tables from search engines
- optdepends = python-lxml: for XML parsing modules, recommended
+ optdepends = python-lxml: for XML parsing modules
optdepends = python-numpy: for most of features, highly recommended
options = !emptydirs
- source = https://pypi.python.org/packages/source/p/pyteomics/pyteomics-3.1.1.tar.gz
- md5sums = e367dc7eb11fd7d589183ec7e9b15650
+ source = https://pypi.io/packages/source/p/pyteomics/pyteomics-3.4.tar.gz
+ md5sums = 3c8d1bcc16c53100e531a10a2853f679
pkgname = python-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 94f5eae040c7..15672ad90dd2 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,10 +1,106 @@
+3.4
+---
+
+ - New module :py:mod:`pyteomics.mzxml` for parsing of MzXML files.
+
+ - New parameter `dtype` in :py:func:`pyteomics.mgf.read`, :py:func:`pyteomics.mzml.read`
+ and :py:func:`pyteomics.mzxml.read`
+ allows changing the dtype of arrays yielded by the parsers.
+
+ - :py:mod:`pyteomics.featurexml` moved into a subpackage :py:mod:`pyteomics.openms`.
+
+ - New module :py:mod:`pyteomics.openms.trafoxml` for OpenMS transformation files.
+
+ - Bugfix in XML indexing code to make it work on Python 3.x versions prior to 3.5.
+
+ - Bugfix in :py:func:`pyteomics.pylab_aux.scatter_trend` (support for lists and other non-ndarrays).
+
+ - Performance improvements in :py:mod:`pyteomics.achrom` calibration functions.
+
+3.3.1
+-----
+
+New submodule :py:mod:`pyteomics.featurexml` with a parser for OpenMS **featureXML** files.
+
+3.3
+---
+
+ - mzML and mzIdentML parsers can now create an index of element offsets.
+ This allows quick random access to elements by unique ID.
+
+ - mzML parsers now come in two flavors: :py:class:`pyteomics.mzml.MzML` and
+ :py:class:`pyteomics.mzml.PreIndexedMzML`. The latter uses the byte offsets
+ listed at the end of the file.
+
+ - New parameters `convert_arrays` and `read_charges` in :py:func:`mgf.read`
+ allow using it without :py:mod:`numpy` and possibly improve performance.
+ The default behavior is retained.
+
+ - Performance optimizations in :py:func:`mgf.read` and :py:func:`parser.cleave`.
+
+ - New decoy generation mode called "fused decoy", described in the paper accepted to JASMS.
+
+API changes
+...........
+
+ - :py:func:`pyteomics.parser.cleave` no longer accepts the `labels` argument.
+ It is emphasized that the input sequences are expected to be in plain one-letter
+ notation, but no checks are performed.
+
+ - :py:func:`DataFrame` functions in :py:mod:`pepxml` and :py:mod:`tandem` now
+ extract more protein-related information. The list-like protein-related values
+ can be reported as lists or packed into strings, depending on the optional
+ paramter `sep`. Some column names have changed as a result.
+
+ - Call signatures of :py:func:`pyteomics.fasta.decoy_sequence` and the functions using it
+ are slightly changed. Standard modes are now also exposed as individual functions.
+
+3.2
+---
+
+New submodule :py:mod:`pyteomics.mass.unimod` contains rewritten machinery
+for handling of Unimod relational databases (contributed by Joshua Klein).
+This is a substitution and extension for the old :py:class:`mass.Unimod` class.
+:py:mod:`pyteomics.mass.unimod` requires SQLAlchemy.
+
+Other changes:
+
+ - New function :py:func:`pyteomics.auxiliary.linear_regression_perpendicular`
+ provides a linear fit minimizing distances from data points to the fit line
+ (as opposed to :py:func:`pyteomics.auxiliary.linear_regression`, which
+ minimizes vertical distances).
+
+ - Both new and old linear regression functions now accept a single array of shape (N, 2).
+
+ - :py:func:`pyteomics.pylab_aux.scatter_trend` now has an optional parameter
+ `regression` which can be a callable performing the regression.
+ Also, the regression equation is now the label of the regression line, not
+ the scatter plot.
+
+ - Another two new parameters for :py:func:`pyteomics.pylab_aux.scatter_trend`
+ are `sigma_kwargs` and `sigma_values`.
+
+ - :py:mod:`pyteomics.pylab_aux` functions :py:func:`plot_line` and
+ :py:func:`scatter_trend` now return the objects they create.
+
+ - Writer functions (:py:func:`pyteomics.mgf.write`, :py:func:`pyteomics.fasta.write`,
+ :py:func:`pyteomics.fasta.write_decoy_db`) now accept a `file_mode` argument that
+ overrides the mode in which the file is opened.
+
+ - In :py:func:`pyteomics.mgf.write` one can now override the format spec for fragment m/z,
+ intensity and charge values using the optinal `fragment_format` argument. Key order and
+ key-value parameter formatters are now also handled via optional arguments.
+
+ - :py:func:`pyteomics.fasta.decoy_db` now supports `ignore_comments` and `parser` arguments.
+
+
3.1.1
-----
- Bugfix in :py:mod:`pyteomics.auxiliary`.
- New parameter `show_legend` in :py:func:`pyteomics.pylab_aux.scatter_trend`.
-
+
- Performance improvements in :py:mod:`pyteomics.parser`.
3.1
@@ -176,8 +272,10 @@ Fix for a memory leak in :py:func:`pyteomics.mzid.get_by_id`, which affects
-----
- Bugfixes in :py:func:`pyteomics.parser.isoforms`:
- - handling of the `labels` argument is now in accordance with new policy
- - solved memory problems when using `max_mods`
+
+ - handling of the `labels` argument is now in accordance with new policy
+ - solved memory problems when using `max_mods`
+
- :py:func:`pyteomics.parser.cleave` does not require a valid *modX* sequence
by default.
diff --git a/PKGBUILD b/PKGBUILD
index 9d116430e60f..5c1b9a7c5cfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
-pkgver=3.1.1
+pkgver=3.4
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
url="http://pythonhosted.org/pyteomics"
license=('Apache')
depends=('python' 'python-setuptools')
-optdepends=('python-matplotlib: for pylab_aux module, optional'
+optdepends=('python-matplotlib: for pylab_aux module'
+ 'python-sqlalchemy: for mass.unimod module'
'python-pandas: for convenient filtering of CSV tables from search engines'
- 'python-lxml: for XML parsing modules, recommended'
+ 'python-lxml: for XML parsing modules'
'python-numpy: for most of features, highly recommended')
options=(!emptydirs)
-source=("https://pypi.python.org/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-md5sums=('e367dc7eb11fd7d589183ec7e9b15650')
+source=("https://pypi.io/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
+md5sums=('3c8d1bcc16c53100e531a10a2853f679')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"