summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2019-01-05 21:44:49 +0300
committerLev Levitsky2019-01-05 21:44:49 +0300
commit9ccfb0da7b2b5555fee2d88fced879ae57b3a4cb (patch)
treef24b02f2db99f8b2249dce88eab2f0d53f0f1999
parentd38dd01aa9c11450ae99f077ba84dafc108cf507 (diff)
downloadaur-9ccfb0da7b2b5555fee2d88fced879ae57b3a4cb.tar.gz
4.0 release
-rw-r--r--.SRCINFO9
-rw-r--r--CHANGELOG86
-rw-r--r--PKGBUILD7
3 files changed, 96 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 723b096cf545..fd04b858a2f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Sat Jan 5 18:44:31 UTC 2019
pkgbase = python-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 3.5.1
+ pkgver = 4.0
pkgrel = 1
url = https://pyteomics.readthedocs.io
changelog = CHANGELOG
@@ -13,9 +15,10 @@ pkgbase = python-pyteomics
optdepends = python-pandas: for convenient filtering of CSV tables from search engines
optdepends = python-lxml: for XML parsing modules
optdepends = python-numpy: for most of features, highly recommended
+ optdepends = python-dill: needed for multiprocessing when pickle is not enough
options = !emptydirs
- source = https://pypi.io/packages/source/p/pyteomics/pyteomics-3.5.1.tar.gz
- sha256sums = acd95d8e139e42c113f3f0bc4f512b9a7081d94eefd5bd73e183e1b4a848c364
+ source = https://pypi.io/packages/source/p/pyteomics/pyteomics-4.0.tar.gz
+ sha256sums = c1d70be8e9b16200e7654f8107356a9e7bdbb8828b6dac04372bd0230e47fbd0
pkgname = python-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 77c44243f0ae..fd49134a727c 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,89 @@
+4.0
+---
+
+ .. seealso::
+ `Pyteomics 4.0: five years of development of a Python proteomics framework
+ <https://pubs.acs.org/doi/10.1021/acs.jproteome.8b00717>`_
+
+
+ - Add parameters `semi` and `exception` in :py:func:`pyteomics.parser.cleave`.
+
+ - Add new parameter `encoding` in file writers.
+
+ - Add new parameters `write_charges` and `use_numpy` in :py:func:`pyteomics.mgf.write`.
+ Speed up the writing when :py:mod:`numpy` is available.
+
+ - :ref:`Indexing text parsers <indexing>`. This release introduces a family of parser classes for text files.
+ These parsers create byte offsets of indexed entries to allow random access by unique key or by positional index,
+ "rich" access by slices and, in case of MGF/mzML/mzXML, by retention time range.
+ All indexing parsers, text- or XML-based, now have a unified interface.
+
+ - New class :py:class:`pyteomics.mgf.IndexedMGF` is now the recommended way to parse MGF files.
+ It supports fast access by spectrum titles by using an index of byte offsets.
+ The old, sequential parser is preserved under its name, :py:class:`pyteomics.mgf.MGF`.
+ The function :py:func:`pyteomics.mgf.read` now returns an instance of one of the two classes,
+ based on the `use_index` argument and the type of `source`.
+ The common ancestor class, :py:class:`pyteomics.mgf.MGFBase`, can be used for type checking.
+
+ - New FASTA parsing classes:
+
+ - :py:class:`pyteomics.fasta.FASTABase` - common ancestor, suitable for type checking;
+
+ - :py:class:`pyteomics.fasta.FASTA` - text-mode, sequential parser; does
+ what the old :py:func:`fasta.read` was doing. Additionally, the following subclasses perform
+ format-specific parsing of FASTA headers:
+
+ - :py:class:`pyteomics.fasta.UniProt`;
+ - :py:class:`pyteomics.fasta.UniParc`;
+ - :py:class:`pyteomics.fasta.UniRef`;
+ - :py:class:`pyteomics.fasta.UniMes`;
+ - :py:class:`pyteomics.fasta.SPD`;
+ - :py:class:`pyteomics.fasta.NCBI`;
+
+ - :py:class:`pyteomics.fasta.IndexedFASTA` - binary-mode, indexing parser.
+ Supports direct indexing by header string;
+
+ - :py:class:`pyteomics.fasta.TwoLayerIndexedFASTA` - additionally supports
+ indexing by extracted header fields. Format-specific second indexes are available in
+ subclasses:
+
+ - :py:class:`pyteomics.fasta.IndexedUniProt`;
+ - :py:class:`pyteomics.fasta.IndexedUniParc`;
+ - :py:class:`pyteomics.fasta.IndexedUniRef`;
+ - :py:class:`pyteomics.fasta.IndexedUniMes`;
+ - :py:class:`pyteomics.fasta.IndexedSPD`;
+ - :py:class:`pyteomics.fasta.IndexedNCBI`.
+
+ :py:func:`pyteomics.fasta.read` now returns an instance of one of these classes,
+ depending on the arguments `use_index` and `flavor`.
+
+ - :py:class:`pyteomics.ms1.IndexedMS1` and :py:class:`pyteomics.ms1.MS1` are available for ms1 format.
+
+ *(In collaboration with J. Klein)*
+
+ - Multiprocessing support: all indexed XML and text file parsers now expose a :py:meth:`map` method.
+ This method can map a user-supplied function to each file entry in separate processes (or simply
+ parallelize the parsing itself).
+ Additionally, objects returned by :py:func:`chain` functions and :py:meth:`iterfind` methods also expose
+ the :py:meth:`map` interface to allow parallelizing the work over multiple files and when iterating over
+ non-default XML tree elements.
+ The order of entries is not preserved in the output.
+ *(In collaboration with J. Klein)*
+
+ - New module :py:mod:`pyteomics.peff` implements the :py:class:`IndexedPEFF` parser for protein databases
+ in the new PSI standard format, `PEFF <http://www.psidev.info/peff>`_. *(Contributed by J. Klein)*
+
+ - New module :py:mod:`pyteomics.traml` implements the :py:class:`TraML` parser for the PSI standard format
+ for SRM data, `TraML <http://www.psidev.info/traml>`_. *(In collaboration with J. Klein)*
+
+ - :py:class:`pyteomics.protxml.ProtXML` now also supports indexing and multiprocessing.
+
+ - Removed parameter `skip_empty_cvparam_values` in XML parsers. In cvParam elements, missing "value"
+ attribute is now always equivalent to the case when it is equal to an empty string. This affects
+ the structure of items produced by MzML and MzIdentML parsers.
+
+ - Multiple fixes and improvements.
+
3.5.1
-----
diff --git a/PKGBUILD b/PKGBUILD
index 6ad7829be767..7a5b7ba1f54f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
-pkgver=3.5.1
+pkgver=4.0
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -11,10 +11,11 @@ optdepends=('python-matplotlib: for pylab_aux module'
'python-sqlalchemy: for mass.unimod module'
'python-pandas: for convenient filtering of CSV tables from search engines'
'python-lxml: for XML parsing modules'
- 'python-numpy: for most of features, highly recommended')
+ 'python-numpy: for most of features, highly recommended'
+ 'python-dill: needed for multiprocessing when pickle is not enough')
options=(!emptydirs)
source=("https://pypi.io/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-sha256sums=('acd95d8e139e42c113f3f0bc4f512b9a7081d94eefd5bd73e183e1b4a848c364')
+sha256sums=('c1d70be8e9b16200e7654f8107356a9e7bdbb8828b6dac04372bd0230e47fbd0')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"