summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2019-05-06 19:16:25 +0300
committerLev Levitsky2019-05-06 19:16:25 +0300
commitb1644e9d3354eda4f974dd3248f7c4c29cabfea3 (patch)
tree2b7b46ea0de83fd59bdfe675bcee9a7ee84bd81a
parent42d4830de2c03d4c056ae5a552fa3efc0c226beb (diff)
downloadaur-b1644e9d3354eda4f974dd3248f7c4c29cabfea3.tar.gz
Release 4.1.1
-rw-r--r--.SRCINFO7
-rw-r--r--CHANGELOG19
-rw-r--r--PKGBUILD7
3 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e2332aad725..f2c21eaa676f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-pyteomics
pkgdesc = A framework for proteomics data analysis.
- pkgver = 4.1
+ pkgver = 4.1.1
pkgrel = 1
url = https://pyteomics.readthedocs.io
changelog = CHANGELOG
@@ -14,9 +14,10 @@ pkgbase = python-pyteomics
optdepends = python-lxml: for XML parsing modules
optdepends = python-numpy: for most of features, highly recommended
optdepends = python-dill: needed for multiprocessing when pickle is not enough
+ optdepends = python-pynumpress: for Numpress support
options = !emptydirs
- source = https://pypi.io/packages/source/p/pyteomics/pyteomics-4.1.tar.gz
- sha256sums = d7eaa5a1c6f25a39a42c4846e8c39e23cd3ba6f1aeeeedb730c3911c82bf6633
+ source = https://pypi.io/packages/source/p/pyteomics/pyteomics-4.1.1.tar.gz
+ sha256sums = 384e4e5eabdbfec39d7c38369278e386a074c7066f33052d7c313af40f1aa45e
pkgname = python-pyteomics
diff --git a/CHANGELOG b/CHANGELOG
index 7f415978efda..72f042ff3daf 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,22 @@
+4.1.1
+-----
+
+ - Add `numpress <https://dx.doi.org/10.1074%2Fmcp.O114.037879>`_ support for mzML and mzXML files.
+ To read files compressed with Numpress, install `pynumpress`
+ (`PyPI <https://pypi.org/project/pynumpress/>`_, `GitHub <https://github.com/mobiusklein/pynumpress>`_).
+
+ .. note:: There is a `known issue
+ <https://bitbucket.org/levitsky/pyteomics/issues/37/add-numpress-support-in-mzml#comment-51540079>`_
+ with `pynumpress` on Linux and Python 2.7, which is contingent on a fix in Cython.
+
+ - Bugfixes.
+
+API changes
+...........
+
+ - In :py:func:`ms1.read` and :py:func:`ms2.read`, the default value for `use_index` is now :py:const:`False`.
+ Using the indexed parsers may result in incorrect behavior if the "first" scan number in S-lines is not unique.
+
4.1
---
diff --git a/PKGBUILD b/PKGBUILD
index c1025ff0e9ef..6c76b940cb89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lev Levitsky <levlev at mail dot ru>
pkgname=python-pyteomics
-pkgver=4.1
+pkgver=4.1.1
pkgrel=1
pkgdesc="A framework for proteomics data analysis."
arch=('any')
@@ -12,10 +12,11 @@ optdepends=('python-matplotlib: for pylab_aux module'
'python-pandas: for convenient filtering of CSV tables from search engines'
'python-lxml: for XML parsing modules'
'python-numpy: for most of features, highly recommended'
- 'python-dill: needed for multiprocessing when pickle is not enough')
+ 'python-dill: needed for multiprocessing when pickle is not enough'
+ 'python-pynumpress: for Numpress support')
options=(!emptydirs)
source=("https://pypi.io/packages/source/p/pyteomics/pyteomics-${pkgver}.tar.gz")
-sha256sums=('d7eaa5a1c6f25a39a42c4846e8c39e23cd3ba6f1aeeeedb730c3911c82bf6633')
+sha256sums=('384e4e5eabdbfec39d7c38369278e386a074c7066f33052d7c313af40f1aa45e')
changelog="CHANGELOG"
package() {
cd "${srcdir}/pyteomics-${pkgver}"